aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e27801eeb7..e8705dc7d2 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -457,7 +457,7 @@ without requiring the source code to be rewritten.")
(define-public guile-next
(let ((version "3.0.9")
(revision "0")
- (commit "db7efa5d204b2e46ce9eb82f417d8c12d394858d"))
+ (commit "3b76a30e3ca1f0b7ee7944836c2fc5660596b3bd"))
(package
(inherit guile-3.0)
(name "guile-next")
@@ -471,7 +471,7 @@ without requiring the source code to be rewritten.")
(file-name (git-file-name name version))
(sha256
(base32
- "1mg7pd0ya7i9swgnb38ay99cjwiw61ni0ypyywjrpv6iyvmx8m8q"))))
+ "1cgyjz1x8zpfhsw8gsqkak1lnmi780gps6874ks0bi8dwk0lwx6f"))))
(arguments
(substitute-keyword-arguments (package-arguments guile-3.0)
((#:phases phases '%standard-phases)
@@ -830,7 +830,7 @@ type system, elevating types to first-class status.")
(define-public guile-git
(package
(name "guile-git")
- (version "0.6.0")
+ (version "0.7.0")
(home-page "https://gitlab.com/guile-git/guile-git.git")
(source (origin
(method git-fetch)
@@ -840,7 +840,7 @@ type system, elevating types to first-class status.")
(file-name (git-file-name name version))
(sha256
(base32
- "0a3765chjas1dmkl0qc75y6l3hsss6n2awi82jkwzjyfslrlcrgq"))))
+ "1dgxzyn6ra685hp2vdhvw4z2hzx16nsjqj5k4p773x5a33jaq4pg"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
@@ -922,17 +922,21 @@ Guile's foreign function interface.")
(define-public guile-lzlib
(package
(name "guile-lzlib")
- (version "0.0.2")
+ (version "0.3.0")
+ (home-page "https://notabug.org/guile-lzlib/guile-lzlib")
(source
(origin
+ ;; Note: Until "builtin:git-download" can be taken for granted, this
+ ;; must be 'url-fetch', not 'git-fetch', to avoid a circular dependency
+ ;; with the 'git-fetch' derivation on systems that lack
+ ;; "builtin:git-download".
(method url-fetch)
- (uri
- (string-append "https://notabug.org/guile-lzlib/guile-lzlib/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (string-append home-page "/archive/" version ".tar.gz"))
+ ;; content nar-sha256: 19870njb3q5h6zy239gvra92ji077c6s8xm0hgcn42z74q5wqnk6
+ (file-name (string-append "guile-lzlib-" version ".tar.gz"))
(sha256
(base32
- "11sggvncyx08ssp1s5xii4d6nskh1qwqihnbpzzvkrs7sivxn8w6"))))
+ "1whgmwkr1v8m63p4aaqn8blwl9vcrswwhbfv4bm0aghl5a6rryd7"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
@@ -944,7 +948,6 @@ Guile's foreign function interface.")
"This package provides Guile bindings for lzlib, a C library for
in-memory LZMA compression and decompression. The bindings are written in
pure Scheme by using Guile's foreign function interface.")
- (home-page "https://notabug.org/guile-lzlib/guile-lzlib")
(license license:gpl3+)))
(define-public guile2.2-lzlib