aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm103
1 files changed, 67 insertions, 36 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c0b0dfd78c..da419030a0 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2018, 2019, 2020, 2021, 2022, 2023 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018–2024 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
@@ -49,6 +49,7 @@
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Artyom Bologov <mail@aartaka.me>
+;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -77,6 +78,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages disk)
#:use-module (gnu packages emacs)
@@ -145,14 +147,14 @@
(define-public artanis
(package
(name "artanis")
- (version "0.5.1")
+ (version "0.6")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/artanis/artanis-"
version ".tar.gz"))
(sha256
(base32
- "1zfg49s7wp37px7k22qcr06rxfwyn3gv1c3jmma346xw0m8jr63w"))
+ "1y4mf8vv2fwjg4z8c4d7an5rxi96sh7krk0djnafm2l66i97cj3m"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -191,7 +193,7 @@
;; projects.
;; TODO: Add guile-dbi and guile-dbd optional dependencies.
(propagated-inputs
- (list guile-json-3 guile-readline guile-redis))
+ (list guile-json-3 guile-curl guile-readline guile-redis))
(native-inputs
(list bash-minimal ;for the `source' builtin
pkg-config
@@ -557,6 +559,33 @@ $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
dictionary and suggesting spelling corrections.")
(license license:gpl3+)))
+(define-public guile-avatar
+ (let ((commit "c2860952fd09ecc878c3d4f1ee2f1678668fbb7a")
+ (revision "0"))
+ (package
+ (name "guile-avatar")
+ (version (git-version "0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/lechner/guile-avatar")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1dq9zcx4q3m5s3cpixq4zvlmdrlcc626mpqb7nmmj7vnda8k717f"))))
+ (build-system guile-build-system)
+ (arguments
+ (list #:source-directory "scm"))
+ (inputs (list guile-3.0))
+ (propagated-inputs (list guile-hashing))
+ (home-page "https://codeberg.org/lechner/guile-avatar")
+ (synopsis "Get Libravatar URLs from an email address")
+ (description
+ "@code{guile-avatar} helps you to determine avatars (or profile
+pictures) for email addresses using the Libravatar specification.")
+ (license license:agpl3+))))
+
(define-public guile2.0-bash
;; This project is currently retired. It was initially announced here:
;; <https://lists.gnu.org/archive/html/guile-user/2015-02/msg00003.html>.
@@ -1120,7 +1149,7 @@ for calling methods on remote servers by exchanging JSON objects.")
(define-public guile-ares-rs
(package
(name "guile-ares-rs")
- (version "0.9.3")
+ (version "0.9.4")
(source
(origin
(method git-fetch)
@@ -1130,7 +1159,7 @@ for calling methods on remote servers by exchanging JSON objects.")
(file-name (git-file-name name version))
(sha256
(base32
- "021lg06c5lrp2j1qv8hl4jh4yq07k158h824kjv6b87bxqk7vq54"))))
+ "0ksj39ka8n7cbsqf56z67hyk2jcjz6zlkgnbdrqa9kp95p47xp41"))))
(build-system guile-build-system)
(arguments
(list
@@ -2026,8 +2055,8 @@ for MySQL.")
(license license:gpl2+)))
(define-public guile-lmdb
- (let ((commit "ea9aa1d4b13e03f9fd23ec73d8884f4fae79666b")
- (revision "1"))
+ (let ((commit "56a986f5db5b70b6bec3ba3e6c161267dd8fda29")
+ (revision "2"))
(package
(name "guile-lmdb")
(version (git-version "0.0.1" revision commit))
@@ -2039,7 +2068,7 @@ for MySQL.")
(file-name (git-file-name name version))
(sha256
(base32
- "1li92ldyjvbqkhqnkndgw0jk1avkzq9jkbmk8dqiby4na72sxi8k"))))
+ "1pzqgdm0dlz3v7nac1akpxrmxgbi2ycyxs7fnn3kba65424vigm7"))))
(build-system guile-build-system)
(arguments
(list
@@ -2064,6 +2093,8 @@ Several conveniences are added on top:
@code{call-with-wrapped-cursor} helpers and respective @code{with-} macros.
@item @code{for-cursor} procedure for cursor iteration.
@item @code{val} and @code{stat} types.
+@item @code{set-compare!} and @code{set-dupsort!} to configure entry
+sorting.
@item Error signaling instead of integer return values.
@end itemize")
(license license:gpl3+))))
@@ -2734,12 +2765,14 @@ library.")
version ".tar.gz"))
(sha256
(base32
- "1nb7swbliw9vx1ivhgd2m0r0p7nlkszw6s41zcgfwb5v1kp05sb4"))))
+ "1nb7swbliw9vx1ivhgd2m0r0p7nlkszw6s41zcgfwb5v1kp05sb4"))
+ (patches (search-patches "guile-lib-fix-tests-for-guile2.2.patch"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0") ;placate guild warnings
#:phases
(modify-phases %standard-phases
+ (delete 'strip)
(add-before 'configure 'patch-module-dir
(lambda _
(substitute* "src/Makefile.in"
@@ -3489,7 +3522,7 @@ from @code{tree-il}.")
(define-public guile-hoot
(package
(name "guile-hoot")
- (version "0.4.0")
+ (version "0.4.1")
(source (origin
(method url-fetch)
(uri (string-append "https://spritely.institute/files/releases"
@@ -3497,7 +3530,7 @@ from @code{tree-il}.")
version ".tar.gz"))
(sha256
(base32
- "0mlj9b9dzhd8k8jg9fgwxyxdy8rsynfq81vm00rjgbh2ivpgr3x2"))))
+ "08bp2dl688ap18h9d840g0dpk71rb3v9r0fmwdjrkwwwsryrjr0n"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0"
@@ -4521,8 +4554,8 @@ function: raw, typed, and functional.")
(license license:lgpl3+))))
(define-public guile-gsl
- (let ((commit "e6d1477b0d0456f500c32610a5cae6ebb1b8acfe")
- (revision "0"))
+ (let ((commit "22ac81c45f33f897d7cc88744d427a6959682c24")
+ (revision "1"))
(package
(name "guile-gsl")
(version (git-version "0.0.1" revision commit))
@@ -4534,7 +4567,7 @@ function: raw, typed, and functional.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1b4brimmg3phahia9dm0wkcp1f29wnbvmi0q8di5sz7pf7qjzsy0"))))
+ (base32 "0gwxyd5flq107ibqdqvx7dl5z23an171jwckn7dvlqc60b7n2x64"))))
(build-system guile-build-system)
(arguments
(list
@@ -4556,7 +4589,7 @@ function: raw, typed, and functional.")
(synopsis "Bindings for GNU Scientific library in Guile")
(description
"This package provides a Guile Scheme wrapper for @code{libgsl.so}.
-Implements vector, matrix,and BLAS operations.")
+Implements vector, matrix, and BLAS operations.")
(license license:gpl3+))))
(define-public guile-ffi-fftw
@@ -4925,31 +4958,27 @@ over, or update a value in arbitrary data structures.")
(define-public guile-xapian
(package
(name "guile-xapian")
- (version "0.3.1")
- (home-page "https://git.systemreboot.net/guile-xapian")
+ (version "0.4.0")
(source
(origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append "https://guile-xapian.systemreboot.net/releases/guile-xapian-"
+ version ".tar.lz"))
(sha256
(base32
- "0axbahbi52ji0fxhykn642265v58rdp2yqliqv456nqs038wb5ja"))))
+ "1szjwha8rin65mdm0dviha4pybiij89pq1wfjmrir1js4w5mk1hr"))))
(build-system gnu-build-system)
(arguments
'(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
(inputs
(list guile-3.0 xapian zlib))
(native-inputs
- (list autoconf
- autoconf-archive
- automake
- libtool
- pkg-config
+ (list pkg-config
+ lzip
swig))
(propagated-inputs
(list guile-lib))
+ (home-page "https://guile-xapian.systemreboot.net")
(synopsis "Guile bindings for Xapian")
(description "@code{guile-xapian} provides Guile bindings for Xapian, a
search engine library. Xapian is a highly adaptable toolkit which allows
@@ -5409,7 +5438,7 @@ Scheme.")
(define-public guile-jwt
(package
(name "guile-jwt")
- (version "0.2.0")
+ (version "0.3.0")
(source
(origin
(method git-fetch)
@@ -5419,12 +5448,12 @@ Scheme.")
(file-name (git-file-name name version))
(sha256
(base32
- "1p8sapiv5im18rjnzc8xnw6y7dr661rycf9g10z5ww0dl4rfz3z1"))))
+ "04c5aibcfb83bl194j27cw5x8bfbqvq5939brckaaapbrff6il6k"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake pkg-config))
(propagated-inputs
- (list guile-json-4))
+ (list guile-gcrypt guile-json-4))
(inputs
(list guile-3.0))
(home-page "https://github.com/aconchillo/guile-jwt")
@@ -6121,7 +6150,7 @@ in two different guises.")
(define-public guile-tap
(package
(name "guile-tap")
- (version "0.4.6")
+ (version "0.5.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6130,7 +6159,7 @@ in two different guises.")
(file-name (git-file-name name version))
(sha256
(base32
- "04ip5cbvsjjcicsri813f4711yh7db6fvc2px4788rl8p1iqvi6x"))))
+ "0yimi9ci5h6wh7bs3ir7p181pwbd2hxlhx7pqq53gr54mnad8qv4"))))
(build-system gnu-build-system)
(arguments
(list #:phases
@@ -6139,7 +6168,9 @@ in two different guises.")
(lambda _
(substitute* "Makefile"
(("PREFIX = /usr/local") (string-append "PREFIX="
- #$output)))))
+ #$output)))
+ (substitute* "bin/tap-harness"
+ ((" guile ") (string-append " " (which "guile") " ")))))
(replace 'build
(lambda _
(invoke "make")
@@ -6203,7 +6234,7 @@ This module implements this interface by use of Guile's dynamic FFI.")
(define-public guile-goblins
(package
(name "guile-goblins")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
@@ -6212,7 +6243,7 @@ This module implements this interface by use of Guile's dynamic FFI.")
version ".tar.gz"))
(sha256
(base32
- "1w1xf60i6an4fs2kr0cv7w01h2fhz1i23zp9w7nbmr32zqm8m59z"))))
+ "1s1aahak0m2hygnwi09vb399w7idh2hmbbn0fi7mdky0scxb5ybr"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags