aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c66a3e5a17..6ab9707798 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -61,6 +61,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages mono)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1497,3 +1498,32 @@ Parcellite and adds bugfixes and features.")
it does not deal with windowing system surfaces, drawing, scene graphs, or
input.")
(license license:expat)))
+
+(define-public gtk-sharp
+ (package
+ (name "gtk-sharp")
+ (version "2.99.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "18n3l9zcldyvn4lwi8izd62307mkhz873039nl6awrv285qzah34"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("mono" ,mono)
+ ("pango" ,pango)
+ ("atk" ,atk)
+ ("gtk+" ,gtk+-2)
+ ("glib" ,glib)))
+ (home-page "https://live.gnome.org/GnomeArt")
+ (synopsis "Theming engines for GTK+ 2.x")
+ (description
+ "This package contains the standard GTK+ 2.x theming engines including
+Clearlooks, Crux, High Contrast, Industrial, LighthouseBlue, Metal, Mist,
+Redmond95 and ThinIce.")
+ (license (list license:gpl2+ license:lgpl2.1+))))