aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 57b15435df..3c19f5abb1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -7349,71 +7349,6 @@ system.")
formatting information, rather than the current locale name.")
(license license:expat))))
-(define-public go-github-com-prometheus-common
- (package
- (name "go-github-com-prometheus-common")
- (version "0.55.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/prometheus/common")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0bsbxil7qz8rhckhv0844nmn38g7i7347cjv5m6na47hbdpi0rqh"))
- (modules '((guix build utils)))
- (snippet
- #~(begin
- ;; Submodules with their own go.mod files and packed as
- ;; separated packages:
- ;;
- ;; - github.com/prometheus/common/assets
- ;; - github.com/prometheus/common/sigv4
- (for-each delete-file-recursively
- (list "assets" "sigv4"))))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/prometheus/common"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v"
- ;; "./config/..." requries
- ;; <github.com/prometheus/client_golang/prometheus>,
- ;; which introduce cycle.
- "./expfmt/..."
- "./helpers/..."
- "./model/..."
- "./promlog/..."
- "./route/..."
- "./server/..."))))))))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs
- (list go-github-com-alecthomas-kingpin-v2
- go-github-com-go-kit-log
- go-github-com-google-go-cmp
- go-github-com-julienschmidt-httprouter
- go-github-com-munnerz-goautoneg
- go-github-com-mwitkow-go-conntrack
- go-github-com-prometheus-client-model
- go-golang-org-x-net
- go-golang-org-x-oauth2
- go-google-golang-org-protobuf
- go-gopkg-in-yaml-v2))
- (synopsis "Prometheus metrics")
- (description "This package provides tools for reading and writing
-Prometheus metrics.")
- (home-page "https://github.com/prometheus/common")
- (license license:asl2.0)))
-
(define-public go-github-com-prometheus-procfs
(package
(name "go-github-com-prometheus-procfs")