aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm96
1 files changed, 55 insertions, 41 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index ca35d5c391..baf68b7089 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -14,12 +14,13 @@
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
-;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2023, 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -453,10 +454,10 @@ providing bidirectional mapping values to their names, plus enum convenience
for values.")
(license license:bsd-3)))
-(define-public go-github-com-golang-jwt-jwt-v4
+(define-public go-github-com-golang-jwt-jwt
(package
- (name "go-github-com-golang-jwt-jwt-v4")
- (version "4.5.0")
+ (name "go-github-com-golang-jwt-jwt")
+ (version "3.2.2")
(source
(origin
(method git-fetch)
@@ -465,11 +466,11 @@ for values.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1m7c9lwlmd0lnn0hyby1rb3f4nwn4xcjgca218frj0hi0krqn8kp"))))
+ (base32 "0hq8wz11g6kddx9ab0icl5h3k4lrivk1ixappnr5db2ng2wjks9c"))))
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/golang-jwt/jwt/v4"))
+ #:import-path "github.com/golang-jwt/jwt"))
(home-page "https://github.com/golang-jwt/jwt")
(synopsis "Go implementation of JSON Web Tokens")
(description
@@ -480,6 +481,24 @@ JSON Web Tokens. The currently supported signing algorithms are HMAC SHA,
RSA, RSA-PSS, and ECDSA, though hooks are present for adding your own.")
(license license:expat)))
+(define-public go-github-com-golang-jwt-jwt-v4
+ (package
+ (inherit go-github-com-golang-jwt-jwt)
+ (name "go-github-com-golang-jwt-jwt-v4")
+ (version "4.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/golang-jwt/jwt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m7c9lwlmd0lnn0hyby1rb3f4nwn4xcjgca218frj0hi0krqn8kp"))))
+ (arguments
+ (list
+ #:import-path "github.com/golang-jwt/jwt/v4"))))
+
(define-public go-github-com-golang-jwt-jwt-v5
(package
(inherit go-github-com-golang-jwt-jwt-v4)
@@ -840,37 +859,6 @@ Architecture Processors\" by J. Guilford et al.")
(define-public go-github-com-multiformats-go-multihash
(package
(name "go-github-com-multiformats-go-multihash")
- (version "0.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/multiformats/go-multihash")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1aw4ra22g3l98bk7c3h1n968vi5a3gk528g4byj3xig76r0r731n"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/multiformats/go-multihash"))
- (propagated-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-gxed-hashland-murmur3
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
- go-github-com-mr-tron-base58
- go-golang-org-x-crypto))
- (home-page "https://github.com/multiformats/go-multihash")
- (synopsis "Multihash implementation in Go")
- (description "Multihash implementation in Go.")
- (license license:expat)))
-
-;; XXX: Remove it when all dependent packages are ready to be updated.
-(define-public go-github-com-multiformats-go-multihash-0.2.3
- (package
- (inherit go-github-com-multiformats-go-multihash)
- (name "go-github-com-multiformats-go-multihash")
(version "0.2.3")
(source
(origin
@@ -881,6 +869,7 @@ Architecture Processors\" by J. Guilford et al.")
(file-name (git-file-name name version))
(sha256
(base32 "0ydh94083888xl2r4d1grzgqf3c818mkmdpj008jkh6h7m56wc4w"))))
+ (build-system go-build-system)
(arguments
(list #:go go-1.21
#:import-path "github.com/multiformats/go-multihash"
@@ -902,14 +891,16 @@ Architecture Processors\" by J. Guilford et al.")
(list specification-multihash
specification-multicodec))
(propagated-inputs
- (list go-github-com-gxed-hashland-keccakpg
- go-github-com-minio-blake2b-simd
- go-github-com-minio-sha256-simd
+ (list go-github-com-minio-sha256-simd
go-github-com-mr-tron-base58
go-github-com-multiformats-go-varint
go-github-com-spaolacci-murmur3
go-golang-org-x-crypto
- go-lukechampine-com-blake3))))
+ go-lukechampine-com-blake3))
+ (home-page "https://github.com/multiformats/go-multihash")
+ (synopsis "Multihash implementation in Go")
+ (description "Multihash implementation in Go.")
+ (license license:expat)))
(define-public go-github-com-operatorfoundation-ed25519
(let ((commit "b22b4bd3ddef042eec45f3ee135cd40281fde2b4")
@@ -944,6 +935,29 @@ Architecture Processors\" by J. Guilford et al.")
algorithm.")
(license license:bsd-3))))
+(define-public go-github-com-pion-randutil
+ (package
+ (name "go-github-com-pion-randutil")
+ (version "v0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pion/randutil")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "098isjyvyb8jhrrr57xi45g5m35vb1l92dm5wcy7g2q9x55lvxg5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/pion/randutil"))
+ (home-page "https://github.com/pion/randutil")
+ (synopsis "Helper library for cryptographic and mathmatical randoms")
+ (description
+ "This package provides primitives for generating random values.")
+ (license license:expat)))
+
(define-public go-github-com-protonmail-go-crypto
(package
(name "go-github-com-protonmail-go-crypto")