aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0adb065eb5..5761475c88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12224,7 +12224,13 @@ integrate seamlessly with the GNOME desktop.")
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (setenv "DESTDIR" "/"))))))
+ (setenv "DESTDIR" "/")))
+ (add-before 'configure 'set-qemu-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/installed-media.vala"
+ (("qemu-img")
+ (search-input-file inputs
+ "/bin/qemu-img"))))))))
(native-inputs
(list desktop-file-utils ;for update-desktop-database
gettext-minimal
@@ -12250,6 +12256,7 @@ integrate seamlessly with the GNOME desktop.")
libvirt
libvirt-glib
libxml2
+ qemu-minimal ;for qemu-img
sparql-query
spice-gtk
tracker