aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm143
1 files changed, 121 insertions, 22 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 50efe7b010..06ba868f35 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -37,7 +37,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2019, 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2019, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2019, 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
@@ -72,7 +72,7 @@
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
;;; Copyright © 2022, 2023 zamfofex <zamfofex@twdb.moe>
;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
;;; Copyright © 2022 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
@@ -6230,6 +6230,106 @@ application that locks the keyboard and mouse and instead displays bright
colors, pictures, and sounds.")
(license license:gpl3+)))
+(define-public moonlight-qt
+ (package
+ (name "moonlight-qt")
+ (version "5.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/moonlight-stream/moonlight-qt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1y736vw36lmh2bjymsf4b4ypr76x9lqz7frzpj7sn0vb9y5315"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no test suite
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* _
+ (symlink (string-append
+ #$(this-package-input "sdl2-gamecontrollerdb")
+ "/share/sdl2/gamecontrollerdb.txt")
+ "app/SDL_GameControllerDB/gamecontrollerdb.txt")
+ ;; Unbundle libraries.
+ (substitute* "moonlight-qt.pro"
+ ((" moonlight-common-c.*\n") "")
+ ((" qmdnsengine.*\n") "")
+ ((" h264bitstream.*\n") "")
+ ((" app \\\\") " app")
+ (("app.depends") "INCLUDEPATH +="))
+ (invoke "qmake" (string-append "PREFIX=" #$output)))))))
+ (native-inputs (list pkg-config qttools-5))
+ (inputs (list ffmpeg
+ h264bitstream
+ libva
+ libvdpau
+ moonlight-common
+ openssl
+ opus
+ qmdnsengine
+ qtbase-5
+ qtdeclarative-5
+ qtquickcontrols2-5
+ qtsvg-5
+ sdl2
+ sdl2-ttf
+ sdl2-gamecontrollerdb))
+ (synopsis "GameStream client")
+ (description
+ "Moonlight is an implementation of NVIDIA's GameStream, as used by the
+NVIDIA Shield.")
+ (home-page "https://moonlight-stream.org")
+ (license license:gpl3+)))
+
+(define-public moonlight-common
+ ;; Used as submodule in https://github.com/moonlight-stream/moonlight
+ (let ((commit "5de4a5b85a28d8d639482a1a105c3a06eb67a2fd")
+ (revision "1"))
+ (package
+ (name "moonlight-common")
+ (version (git-version "5.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/moonlight-stream/moonlight-common-c")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "05jm0vhyb6pizd8yj89rp6ak7bf5j9w06rrmbxh8jccxwqjgll92"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'use-system-enet-package
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("add_subdirectory\\(enet\\)")
+ ""))))
+ (replace 'install
+ (lambda* (#:key outputs source #:allow-other-keys)
+ (let* ((include (string-append #$output
+ "/include"))
+ (lib (string-append #$output "/lib")))
+ (mkdir-p include)
+ (mkdir-p lib)
+ (install-file (string-append source
+ "/src/Limelight.h") include)
+ (install-file "libmoonlight-common-c.so" lib)))))))
+ (native-inputs (list pkg-config))
+ (inputs (list enet-moonlight openssl qtbase-5))
+ (synopsis "GameStream protocol core implementation")
+ (description
+ "This package provides the GameStream core code for the protocol.")
+ (home-page "https://github.com/moonlight-stream/moonlight-common-c")
+ (license license:gpl3+))))
+
(define-public mrrescue
(package
(name "mrrescue")
@@ -7099,27 +7199,26 @@ monsters in a quest to find the mystifyingly fabulous Orb of Zot.")
(version "1.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://bitbucket.org/osslugaru/lugaru/downloads/"
- "lugaru-" version ".tar.xz"))
+ (uri (string-append "https://github.com/osslugaru/lugaru/releases"
+ "/download/" version
+ "/lugaru-" version ".tar.xz"))
(sha256
- (base32
- "15zgcshy22q51rm72zi6y9z7qlgnz5iw3gczjdlir4bqmxy4gspk"))))
+ (base32 "15zgcshy22q51rm72zi6y9z7qlgnz5iw3gczjdlir4bqmxy4gspk"))
+ (patches
+ (search-patches "lugaru-fix-sound.patch"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags
- (list "-DSYSTEM_INSTALL=ON")
- ;; no test target
- #:tests? #f))
- (native-inputs
- (list pkg-config))
+ (list #:configure-flags #~(list "-DSYSTEM_INSTALL=ON")
+ #:tests? #f)) ;no test suite
+ (native-inputs (list pkg-config))
(inputs
- `(("sdl2" ,sdl2)
- ("glu" ,glu)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("openal" ,openal)
- ("vorbis" ,libvorbis)
- ("zlib" ,zlib)))
+ (list glu
+ libjpeg-turbo
+ libpng
+ libvorbis
+ openal
+ sdl2
+ zlib))
(home-page "https://osslugaru.gitlab.io")
(synopsis "Cross-platform third-person action game")
(description "Lugaru is a third-person action game. The main character,
@@ -7128,7 +7227,7 @@ In his quest to find those responsible for slaughtering his village, he uncovers
a far-reaching conspiracy involving the corrupt leaders of the rabbit republic
and the starving wolves from a nearby den. Turner takes it upon himself to
fight against their plot and save his fellow rabbits from slavery.")
- (license (list license:gpl2+ ; code
+ (license (list license:gpl2+ ; code
;; assets:
license:cc-by-sa3.0
license:cc-by-sa4.0))))
@@ -11254,7 +11353,7 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
(define-public vcmi
(package
(name "vcmi")
- (version "1.3.2")
+ (version "1.4.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -11263,7 +11362,7 @@ play; it will look for them at @file{~/.local/share/fheroes2} folder.")
(file-name (git-file-name name version))
(sha256
(base32
- "1x1bzd89h0j4xci91d2v5aj5vgkx6vm12iml805wkia4hy1jp4ff"))
+ "039d9dvb2i4y1fj6q5py34r17fwb5jqxkjcg7j57asjk4w9b7i8b"))
(patches (search-patches "vcmi-disable-privacy-breach.patch"))))
(build-system cmake-build-system)
(arguments