aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/fonts.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/fonts.scm')
-rw-r--r--gnu/packages/fonts.scm125
1 files changed, 118 insertions, 7 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 9ec722c19c..a5c8cfadce 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -34,7 +34,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2020, 2021 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
+;;; Copyright © 2020, 2024 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020, 2021, 2022 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
@@ -2473,7 +2473,7 @@ files (TTF).")
(define-public font-mononoki
(package
(name "font-mononoki")
- (version "1.3")
+ (version "1.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2481,7 +2481,7 @@ files (TTF).")
(commit version)))
(sha256
(base32
- "07gh84iw84g8fha3gx4yjyl1rsksqhy2kk38f01m048sgjp6ww5j"))
+ "1mqinvb3hyimga8qjgpwgfv30yddzyicd79shhjbsns91v5z4x33"))
(file-name (git-file-name name version))))
(build-system font-build-system)
(arguments
@@ -2519,7 +2519,7 @@ font that is a composite of IBM Plex Mono and IBM Plex Sans JP.")
(define-public font-public-sans
(package
(name "font-public-sans")
- (version "1.008")
+ (version "2.001")
(source
(origin
(method git-fetch)
@@ -2528,7 +2528,7 @@ font that is a composite of IBM Plex Mono and IBM Plex Sans JP.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qhyxbjv1rnydfpqzd18fbiyz75p4sabphy8yj07hyq0hidp5xsf"))))
+ (base32 "0p3rl4w8m381jxb7in6z9iwjbk1chd7s0gk6jz96c8ci1bddbxk0"))))
(build-system font-build-system)
(home-page "https://public-sans.digital.gov/")
(synopsis "Neutral typeface for interfaces, text, and headings")
@@ -2963,6 +2963,57 @@ to write people's name, or for formal business situations where it is necessary
to have a detailed and proper character style.")
(license license:ipa)))
+(define-public font-jigmo
+ (package
+ (name "font-jigmo")
+ (version "20230816")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://kamichikoichi.github.io/jigmo/Jigmo-"
+ version ".zip"))
+ (sha256
+ (base32 "1higvn4qvz25hx215fs2vqlzh2d2645jbxf07yd82y09drl429jd"))))
+ (build-system font-build-system)
+ (home-page "https://kamichikoichi.github.io/jigmo/")
+ (synopsis "Font contains most CJK unified ideograph characters")
+ (description "Jigmo is a font contains all CJK unified ideograph characters
+in Unicode 15.1 standard, ranges from CJK extension A to CJK extension I.
+It is generated by the font shape data in GlyphWiki using KAGE system, Clipper
+and FontForge.")
+ (license license:cc0)))
+
+(define-public font-plangothic
+ (package
+ (name "font-plangothic")
+ (version "1.8.5760")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/"
+ "Plangothic-Project/releases/download/V"
+ version "/Plangothic.ttc"))
+ (sha256
+ (base32 "0ha2hcgy95ibmjk8lqfz0ihfc09swrzz3grlchma7qrwyxqbwpc0"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let* ((out #$output)
+ (dest (string-append out "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/Plangothic.ttc")))))
+ (home-page
+ "https://github.com/Fitzgerald-Porthmouth-Koenigsegg/Plangothic-Project")
+ (synopsis "Sans font covers most CJK unified ideograph characters")
+ (description "Plangothic is a sans font based on Source Han Sans,
+modified to cover most CJK unified ideograph characters.")
+ (license license:silofl1.1)))
+
(define-public font-fontna-yasashisa-antique
(package
(name "font-fontna-yasashisa-antique")
@@ -3386,6 +3437,66 @@ within GB 2312, standard glyphs for Mainland China is used.")
Song typeface covering commonly used characters as well as written form of
dialects in Hong Kong and Taiwan.")))
+(define-public font-lxgw-neozhisong
+ (package
+ (name "font-lxgw-neozhisong")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWNeoZhiSong.ttf"))
+ (sha256
+ (base32 "02jv5ysd450i47m3qmdwm3w23bp4wlqrjdwk6iirhgpv169p901j"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGWNeoZhiSong.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from IPAmj Mincho")
+ (description "LXGW NeoZhiSong is a Simplified Chinese Song typeface derived
+from IPAmj Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
+(define-public font-lxgw-heartserif
+ (package
+ (name "font-lxgw-heartserif")
+ (version "0.920.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/lxgw/LxgwNeoZhiSong/releases/download/v"
+ version "/LXGWHeartSerif.ttf"))
+ (sha256
+ (base32 "1nbhvy0b9vb0w5pfpp5f0jdkb6fs422avkdxzqydmv74g5v8gz07"))))
+ (build-system trivial-build-system)
+ (arguments
+ (list
+ #:modules '((guix build utils))
+ #:builder
+ #~(let ((out #$output)
+ (dest (string-append #$output "/share/fonts/truetype")))
+ (use-modules (guix build utils))
+ (mkdir-p dest)
+ (copy-file #$(package-source this-package)
+ (string-append dest "/LXGHeartSerif.ttf")))))
+ (home-page "https://github.com/lxgw/LxgwNeoZhiSong")
+ (synopsis "Simplified Chinese Song typeface derived from Kokoro Mincho")
+ (description "LXGW HeartSerif is a Simplified Chinese Song typeface derived
+from Kokoro Mincho, modified to adapt to the standard glyph shape used in
+Mainland China.")
+ (license license:ipa)))
+
(define-public font-chiron-sung-hk
(package
(name "font-chiron-sung-hk")
@@ -3447,7 +3558,7 @@ prevalent typefaces in Traditional Chinese regions.")))
(define-public font-spleen
(package
(name "font-spleen")
- (version "1.9.3")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3455,7 +3566,7 @@ prevalent typefaces in Traditional Chinese regions.")))
version "/spleen-" version ".tar.gz"))
(sha256
(base32
- "09bbwza14pl70cxbr09f9m8522s5p1p04kx9gh8svpd50bdixbdp"))))
+ "0brp1kyp6i5q9zk3hpj5ngxh4js0aw2m6d4yrzxmif3f39pwaiwb"))))
(build-system font-build-system)
(outputs '("out" ;OTB
"bdf" "otf" "pcf" "psf"))