aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm74
1 files changed, 66 insertions, 8 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index a79c70d1e0..579e060d26 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
+;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -69,6 +70,7 @@
#:use-module (gnu packages dbm)
#:use-module (gnu packages gettext)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages graphviz)
@@ -623,7 +625,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.17.1.5")
+ (version "0.17.1.6")
(source
(origin
(method git-fetch)
@@ -643,7 +645,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
"external/unbound"))
#t))
(sha256
- (base32 "0yy9n2qng02j314h8fh5n0mcy6vpdks0yk4d8ifn8hj03f3g2c8b"))))
+ (base32 "0b6zyr3mzqvcxf48i2g45gr649x6nhppik5598jsvg0z7i2hxb9q"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -733,7 +735,7 @@ the Monero command line client and daemon.")
(define-public monero-gui
(package
(name "monero-gui")
- (version "0.17.1.5")
+ (version "0.17.1.6")
(source
(origin
(method git-fetch)
@@ -742,7 +744,7 @@ the Monero command line client and daemon.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0qlcqli0wvrjfy89mbgh1hpmk60dxgn5sws93h8lhgyfwx557iw0"))))
+ (base32 "0kn5wvx2psbdaqmy1cxlbf5l1mdpvh0b6hh9drah3s7nj3654a3r"))))
(build-system qt-build-system)
(native-inputs
`(,@(package-native-inputs monero)
@@ -1229,20 +1231,25 @@ trezord as a regular user instead of needing to it run as root.")
(define-public trezord
(package
(name "trezord")
- (version "2.0.29")
+ (version "2.0.30")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/trezor/trezord-go")
- (commit (string-append "v" version))))
+ (url "https://github.com/trezor/trezord-go")
+ (commit (string-append "v" version))))
(sha256
(base32
- "1ks1fa0027s3xp0z6qp0dxmayvrb4dwwscfhbx7da0khp153f2cp"))
+ "1hzvk0wfgg7b4wpqjk3738yqxlv3pj5i7zxwm0jady2h97hmrqrr"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
'(#:import-path "github.com/trezor/trezord-go"))
+ (native-inputs
+ `(("github.com/gorilla-csrf" ,go-github-com-gorilla-csrf)
+ ("github.com/gorilla/handlers" ,go-github-com-gorilla-handlers)
+ ("github.com/gorilla/mux" ,go-github-com-gorilla-mux)
+ ("gopkg.in/natefinch/lumberjack.v2" ,go-gopkg-in-natefinch-lumberjack.v2)))
(home-page "https://trezor.io")
(synopsis "Trezor Communication Daemon aka Trezor Bridge (written in Go)")
(description "This allows a Trezor hardware wallet to communicate to the
@@ -1648,3 +1655,54 @@ generate a variety of reports from them, and provides a web interface.")
(synopsis "Emacs mode for beancount")
(description
"Emacs-beancount is an Emacs mode for the Beancount accounting tool.")))
+
+(define-public hledger-web
+ (package
+ (name "hledger-web")
+ (version "1.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "hledger-web/hledger-web-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w59nr7mj0nx8z44cvhy1rhlj5rmx0wq4p5nfl4dycfmp7jwvsm1"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-decimal" ,ghc-decimal)
+ ("ghc-aeson" ,ghc-aeson)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-clientsession" ,ghc-clientsession)
+ ("ghc-cmdargs" ,ghc-cmdargs)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-data-default" ,ghc-data-default)
+ ("ghc-hjsmin" ,ghc-hjsmin)
+ ("hledger" ,hledger)
+ ("ghc-hledger-lib" ,ghc-hledger-lib)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-http-conduit" ,ghc-http-conduit)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-json" ,ghc-json)
+ ("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-shakespeare" ,ghc-shakespeare)
+ ("ghc-wai" ,ghc-wai)
+ ("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-wai-handler-launch" ,ghc-wai-handler-launch)
+ ("ghc-warp" ,ghc-warp)
+ ("ghc-yaml" ,ghc-yaml)
+ ("ghc-yesod" ,ghc-yesod)
+ ("ghc-yesod-core" ,ghc-yesod-core)
+ ("ghc-yesod-form" ,ghc-yesod-form)
+ ("ghc-yesod-static" ,ghc-yesod-static)))
+ (home-page "https://hledger.org")
+ (synopsis "Web-based user interface for the hledger accounting system")
+ (description "This package provides a simple Web-based User
+Interface (UI) for the hledger accounting system. It can be used as a
+local, single-user UI, or as a multi-user UI for viewing, adding, and
+editing on the Web.")
+ (license license:gpl3)))