aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9abac359d0..f09a942e0d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1213,6 +1213,41 @@ environment set through Direnv.")
written in the Go programming language.")
(license license:bsd-3)))
+(define-public emacs-cl-lib
+ (package
+ (name "emacs-cl-lib")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://elpa.gnu.org/packages/cl-lib-"
+ version
+ ".el"))
+ (sha256
+ (base32
+ "00w7bw6wkig13pngijh7ns45s1jn5kkbbjaqznsdh6jk5x089j9y"))))
+ (build-system emacs-build-system)
+ (home-page
+ "http://elpa.gnu.org/packages/cl-lib.html")
+ (synopsis
+ "Properly prefixed CL functions and macros")
+ (description
+ "This is a forward compatibility package, which provides (a subset of) the
+features of the cl-lib package introduced in Emacs-24.3, for use on
+previous emacsen (it should work on Emacsā‰„21 as well as XEmacs).
+
+Make sure this is installed *late* in your `load-path`, i.e. after Emacs's
+built-in .../lisp/emacs-lisp directory, so that if/when you upgrade to
+Emacs-24.3, the built-in version of the file will take precedence, otherwise
+you could get into trouble (although we try to hack our way around the
+problem in case it happens).
+
+This code is largely copied from Emacs-24.3's cl.el, with the alias bindings
+simply reversed.")
+ (license license:gpl3+)))
+
+
(define-public emacs-gotest
(package
(name "emacs-gotest")
@@ -1226,6 +1261,13 @@ written in the Go programming language.")
(base32
"1bkma1f5yhb1p782daw2dqbkq1mzr005l5rw19l2pjc9pyg5g05w"))))
(build-system emacs-build-system)
+ (arguments
+ '(;;#:include (cons "^snippets\\/minitest-mode\\/" %default-include)
+ #:exclude (delete "^[^/]*tests?\\.el$" %default-exclude)))
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-f" ,emacs-f)
+ ("emacs-cl-lib" ,emacs-cl-lib)))
(home-page "https://github.com/nlamirault/gotest.el")
(synopsis "")
(description