aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm228
1 files changed, 130 insertions, 98 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 975b26813a..f35aa3e514 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -516,7 +516,7 @@ e.g. emacs-geiser-guile for Guile.")
(define-public emacs-gptel
(package
(name "emacs-gptel")
- (version "0.8.0")
+ (version "0.8.5")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -525,7 +525,7 @@ e.g. emacs-geiser-guile for Guile.")
(file-name (git-file-name name version))
(sha256
(base32
- "1n3kdylv50filla692j2vcjalw6yza80xlg90cw54m9jp9br8sch"))))
+ "1w9sji73dixch1b5i420j44qb3jd0zknpypz46g33pbyhg9xwqln"))))
(build-system emacs-build-system)
(arguments
(list
@@ -1668,6 +1668,10 @@ libgit2 bindings for Emacs, intended to boost the performance of Magit.")
(lambda args
(with-directory-excursion "lisp"
(apply (assoc-ref %standard-phases 'expand-load-path) args))))
+ (replace 'make-autoloads
+ (lambda args
+ (with-directory-excursion "lisp"
+ (apply (assoc-ref %standard-phases 'make-autoloads) args))))
(replace 'install
(lambda args
(with-directory-excursion "lisp"
@@ -2711,15 +2715,25 @@ provides an optional IDE-like error list.")
(list
#:tests? #t
#:test-command
- #~(list "emacs" "-Q" "--batch" "-L" "."
- "--eval" "(load-file \"tests/test-fb2-reader.el\")")
+ #~(list "buttercup" "-L" ".")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'qualify-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((unzip (search-input-file inputs "/bin/unzip")))
(substitute* "fb2-reader.el"
- (("unzip") unzip))))))))
+ (("unzip") unzip)))))
+ (add-after 'unpack 'fix-tests
+ (lambda _
+ ;; Lexical binding is required for compatibility with recent
+ ;; Buttercup.
+ (emacs-batch-edit-file "tests/test-fb2-reader.el"
+ '(progn
+ (insert ";;; -*-lexical-binding:t -*-\n")
+ (basic-save-buffer)))
+ ;; Fix bogus function name.
+ (substitute* "tests/test-fb2-reader.el"
+ (("fb2-reader-render") "fb2-reader-render-xml")))))))
(inputs (list unzip))
(native-inputs
(list emacs-async emacs-buttercup emacs-dash emacs-s))
@@ -4727,7 +4741,7 @@ of bibliographic references.")
(define-public emacs-corfu
(package
(name "emacs-corfu")
- (version "1.2")
+ (version "1.3")
(source
(origin
(method git-fetch)
@@ -4736,7 +4750,7 @@ of bibliographic references.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0l6hpsw2srmad0mhp6x46d5dsg678lvgz5l3glp1845hkg8a0pgi"))))
+ (base32 "1nrwh00dy2ffzd3np8yk4n0vn0r5iqqhgcr40wbnv5qzgbdw9kas"))))
(build-system emacs-build-system)
(arguments
(list
@@ -6494,7 +6508,7 @@ files and directories.")
(define-public emacs-fountain-mode
(package
(name "emacs-fountain-mode")
- (version "3.7.2")
+ (version "3.7.3")
(source
(origin
(method git-fetch)
@@ -6503,7 +6517,7 @@ files and directories.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0xy45inihqwaix49vxr5yiqyps4r2djkzdd4g7kkc0fv7kzrm1m4"))))
+ (base32 "15r0pzdmimm72jx26zgdxf7fwwcppl45vvh33xx5wnhqzd140hwn"))))
(arguments
(list
#:phases #~(modify-phases %standard-phases
@@ -7981,7 +7995,7 @@ mode-line.")
(define-public emacs-robe
(package
(name "emacs-robe")
- (version "0.8.4")
+ (version "0.8.6")
(source
(origin
(method git-fetch)
@@ -7990,7 +8004,7 @@ mode-line.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0kvyfyr4b0z0l964a8z9shy8nlnxzxc2ljcc02gj2pn1rn1wz0gq"))))
+ (base32 "14apmvbs89si3v5hsiz11dckp8fdfidm14lc090lswq7mgk7h79s"))))
(build-system emacs-build-system)
(arguments
'(#:include (cons "^lib\\/" %default-include)))
@@ -10900,7 +10914,7 @@ sgml/html integration, and indentation (working with sgml).")
(define-public emacs-jinx
(package
(name "emacs-jinx")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method git-fetch)
@@ -10910,7 +10924,7 @@ sgml/html integration, and indentation (working with sgml).")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "14zamk2s20f6dnv23v9snya0mi1bs2nq6xpp5bj06kiymzwhcqjw"))))
+ (base32 "0g8sdfq6fqf6jnv7ig9cgkvmrdfzah6c94yr041anzkwappkziwx"))))
(build-system emacs-build-system)
(arguments
(list
@@ -10949,9 +10963,9 @@ sgml/html integration, and indentation (working with sgml).")
(propagated-inputs (list emacs-compat))
(native-inputs (list emacs-compat enchant pkg-config texinfo))
(home-page "https://github.com/minad/jinx")
- (synopsis "Emacs Enchanted Spell Checker")
+ (synopsis "Emacs spell checker based on Enchant library")
(description "Jinx is a just-in-time spell-checker for Emacs
-based on the enchant library. It lazily highlights misspelled words in the
+based on the Enchant library. It lazily highlights misspelled words in the
text of the visible portion of the buffer by honouring window boundaries as
well as text folding, if any.")
(license license:gpl3+)))
@@ -12393,7 +12407,7 @@ expansion and overwriting the marked region with a new snippet completion.")
(define-public emacs-marginalia
(package
(name "emacs-marginalia")
- (version "1.5")
+ (version "1.6")
(source
(origin
(method git-fetch)
@@ -12402,7 +12416,7 @@ expansion and overwriting the marked region with a new snippet completion.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "12ncif2lv6d7r2g87lyjr7idbqa283ijb3qgd5a61i3760czs7d6"))))
+ (base32 "196gjpmzra9azhrnvlhx50dlc59390hq4wxn0f9m4n86ig4i5dr0"))))
(build-system emacs-build-system)
(arguments
(list
@@ -18384,6 +18398,25 @@ package.")
memoizing functions.")
(license license:unlicense)))
+(define-public emacs-memory-usage
+ (package
+ (name "emacs-memory-usage")
+ (version "0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/memory-usage-"
+ version ".el"))
+ (sha256
+ (base32 "03qwb7sprdh1avxv3g7hhnhl41pwvnpxcpnqrikl7picy78h1gwj"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/memory-usage.html")
+ (synopsis "Analyze the memory usage of Emacs in various ways")
+ (description
+ "This package provides the command @code{memory-usage}, which lists all
+buffers and how much memory they use.")
+ (license license:gpl3+)))
+
(define-public emacs-linum-relative
(package
(name "emacs-linum-relative")
@@ -22455,7 +22488,7 @@ the pipeline, featuring the support for running @code{emacsclient}.")
(define-public emacs-jupyter
(package
(name "emacs-jupyter")
- (version "0.8.3")
+ (version "1.0")
(source
(origin
(method git-fetch)
@@ -22464,7 +22497,7 @@ the pipeline, featuring the support for running @code{emacsclient}.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0acn964xlpn265vry35lrkkpf9z5y4ml96xg8ifadkxwxymm1sh2"))))
+ (base32 "0rf8d83bzc05v0w7zpqwcd89cdvrxwzpyf55vmmzj5j755bgxvhs"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-company ;optional
@@ -22903,7 +22936,7 @@ match and total match information in the mode-line in various search modes.")
(define-public emacs-pg
(package
(name "emacs-pg")
- (version "0.30")
+ (version "0.31")
(source (origin
(method git-fetch)
(uri (git-reference (url "https://github.com/emarsden/pg-el")
@@ -22911,7 +22944,7 @@ match and total match information in the mode-line in various search modes.")
(file-name (git-file-name name version))
(sha256
(base32
- "1g04izsnvxinbwvzx0sj643ix5jlwdd7dkl61nvaqkkkm3g35jp6"))))
+ "0h9szmi1l76inr4706s2hpaldzvmnzw1dy7p2cm653pfr6gq8f6x"))))
(build-system emacs-build-system)
(home-page "https://github.com/emarsden/pg-el")
(synopsis "Emacs Lisp interface for PostgreSQL")
@@ -23621,7 +23654,7 @@ interactive commands and functions, such as @code{completing-read}.")
(define-public emacs-org-ql
(package
(name "emacs-org-ql")
- (version "0.8.4")
+ (version "0.8.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -23629,12 +23662,12 @@ interactive commands and functions, such as @code{completing-read}.")
(commit (string-append "v" version))))
(sha256
(base32
- "07r9bx0bh7wyj5pbkhnrn8amzz3ynri94cxcxgcn1r3ypdhk6y85"))
+ "0425r0qjl83d1zq2z9myish3iqa6pc9ml2jlwmffjnj5gm3vgfsj"))
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(arguments
(list
- #:tests? #t
+ #:tests? #f ;FIXME: check phase freezes
#:test-command #~(list "buttercup" "-L" ".")))
(native-inputs
(list emacs-buttercup emacs-with-simulated-input emacs-xr))
@@ -24261,7 +24294,7 @@ given function is invoked.")
(define-public emacs-datetime
(package
(name "emacs-datetime")
- (version "0.9.1")
+ (version "0.10")
(source
(origin
(method git-fetch)
@@ -24270,7 +24303,7 @@ given function is invoked.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0d918312gpdiyx7zq8kdy19bdww6jqg94hs4j5l0n63bwrxsqdx2"))))
+ (base32 "0prc29dhc0yvx1lv9ng9iif1x7c0k7x51x1d1z5pzz0vps0w1qsh"))))
(build-system emacs-build-system)
(arguments
`(#:include (cons "^[^/]*\\.extmap$" %default-include)))
@@ -24278,8 +24311,9 @@ given function is invoked.")
(list emacs-extmap))
(home-page "https://github.com/doublep/datetime/")
(synopsis "Library to work with dates in Emacs")
- (description "Parsing, formatting, matching and recoding
-timestamps and date-time format strings library for Emacs.")
+ (description
+ "Datetime is an Emacs library for parsing, formatting, matching and
+recoding timestamps and date-time format strings.")
(license license:gpl3+)))
(define-public emacs-org-mind-map
@@ -25281,7 +25315,7 @@ powerful Org contents.")
(define-public emacs-org-re-reveal
(package
(name "emacs-org-re-reveal")
- (version "3.26.0")
+ (version "3.28.1")
(source
(origin
(method git-fetch)
@@ -25290,7 +25324,7 @@ powerful Org contents.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "11if1c1a0i6i2wagjwqmvp2hfkv3slpq7r6dfbpkhlmils2hxr9p"))))
+ (base32 "09rcjxqv8i7d87x8cnyblpnm3flpa7mdg609fvbzbs6dsc24zpjl"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-htmlize emacs-org))
@@ -27472,7 +27506,7 @@ image, rotate it, save modified images, and more.")
(define-public emacs-package-lint
(package
(name "emacs-package-lint")
- (version "0.22")
+ (version "0.23")
(source
(origin
(method git-fetch)
@@ -27482,7 +27516,7 @@ image, rotate it, save modified images, and more.")
(file-name (git-file-name name version))
(sha256
(base32
- "1myhdhb3kwq03f3p7qgb9bk8srs1wlag4ch4kl26yb9213mzx8gv"))))
+ "1xr7sq7pvvdw9prf2vds048s5s7fq1s0cxs21sxdc54sszy17nsg"))))
(arguments
(list #:include #~(cons "^data/" %default-include)))
(build-system emacs-build-system)
@@ -29397,7 +29431,7 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
(define-public emacs-buttercup
(package
(name "emacs-buttercup")
- (version "1.34")
+ (version "1.35")
(source
(origin
(method git-fetch)
@@ -29407,7 +29441,7 @@ targets the Emacs based IDEs (CIDER, ESS, Geiser, Robe, SLIME etc.)")
(file-name (git-file-name name version))
(sha256
(base32
- "07bsbzqxsb6sbayriymy54bqcy7is7c61fpnm83mg9527w0w4g19"))))
+ "0s5c7ia7b873dr6rqljkb1z4bf84zb3p3wjvcvpjhdcnf67m5x10"))))
(build-system emacs-build-system)
(arguments
(list
@@ -30654,53 +30688,52 @@ the standard @code{Dockerfile} file format.")
(license license:asl2.0)))
(define-public emacs-lsp-mode
- (let ((commit "26c4d3e54ad2956623e64132312fe864274d346f")
- (revision "1"))
- (package
- (name "emacs-lsp-mode")
- (version (git-version "8.0.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/emacs-lsp/lsp-mode")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0klnik69b5y6s2q00vyshxymlg7k4x9x6m7wpsf7z9w12qn27alx"))))
- (build-system emacs-build-system)
- (arguments
- `(#:emacs ,emacs ;need libxml support
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'move-clients-libraries
- ;; Move all clients libraries at top-level, as is done, e.g., in
- ;; MELPA.
- (lambda _
- (for-each (lambda (f)
- (install-file f "."))
- (find-files "clients/" "\\.el$"))))
- (add-before 'move-clients-libraries 'fix-patch-el-files
- ;; /bin/ksh is only used on macOS, which we don't support, so we
- ;; don't want to add it as input.
- (lambda _
- (substitute* '("clients/lsp-csharp.el" "clients/lsp-fsharp.el")
- (("/bin/ksh") "ksh")))))))
- (propagated-inputs
- (list emacs-dash
- emacs-f
- emacs-ht
- emacs-hydra
- emacs-markdown-mode
- emacs-spinner))
- (home-page "https://emacs-lsp.github.io/lsp-mode/")
- (synopsis "Emacs client and library for the Language Server Protocol")
- (description
- "LSP mode is a client and library implementation for the Language
+ (package
+ (name "emacs-lsp-mode")
+ (version "9.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/lsp-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1p4979qbmllmmszmnyml0msxkza4pm14rdacmqczbfs3cs9n6bd3"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:emacs emacs ;need libxml support
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'move-clients-libraries
+ ;; Move all clients libraries at top-level, as is done, e.g., in
+ ;; MELPA.
+ (lambda _
+ (for-each (lambda (f)
+ (install-file f "."))
+ (find-files "clients/" "\\.el$"))))
+ (add-before 'move-clients-libraries 'fix-patch-el-files
+ ;; /bin/ksh is only used on macOS, which we don't support, so we
+ ;; don't want to add it as input.
+ (lambda _
+ (substitute* '("clients/lsp-csharp.el" "clients/lsp-fsharp.el")
+ (("/bin/ksh") "ksh")))))))
+ (propagated-inputs
+ (list emacs-dash
+ emacs-f
+ emacs-ht
+ emacs-hydra
+ emacs-markdown-mode
+ emacs-spinner))
+ (home-page "https://emacs-lsp.github.io/lsp-mode/")
+ (synopsis "Emacs client and library for the Language Server Protocol")
+ (description
+ "LSP mode is a client and library implementation for the Language
Server Protocol. This mode creates an IDE-like experience by providing
optional integration with other popular Emacs packages like Company, Flycheck,
and Projectile.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define* (%emacs-lsp-treemacs-upstream-source #:key commit version hash)
(origin
@@ -32433,7 +32466,7 @@ through Dash docsets.")
(define-public emacs-devdocs
(package
(name "emacs-devdocs")
- (version "0.6")
+ (version "0.6.1")
(source
(origin
(method url-fetch)
@@ -32441,7 +32474,7 @@ through Dash docsets.")
"https://elpa.gnu.org/packages/"
"devdocs-" version ".tar"))
(sha256
- (base32 "17av2l61mr4y8la4cqiq1dnaznni4xirr5k3wdix1jzl3q1apypy"))))
+ (base32 "04m3jd3wymrsdlb1i7z6dz9pf1q8q38ihkbn3jisdca6xkk9jd6p"))))
(build-system emacs-build-system)
(home-page "https://github.com/astoff/devdocs.el")
(synopsis "Emacs viewer for DevDocs")
@@ -32783,14 +32816,14 @@ well as an option for visually flashing evaluated s-expressions.")
(define-public emacs-tramp
(package
(name "emacs-tramp")
- (version "2.6.2.2")
+ (version "2.6.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://elpa.gnu.org/packages/"
"tramp-" version ".tar"))
(sha256
- (base32 "0bbsff2qr71f70nxhdi19b3jzpv6bgfb7x7qkrccsygvsvgyrb2h"))))
+ (base32 "0z44mfpvn4qy2xc2fsiahw3xir140ljna8aq45dcb7qnmr044xjb"))))
(build-system emacs-build-system)
(arguments
(list
@@ -33820,7 +33853,7 @@ time.")
(define-public emacs-mastodon
(package
(name "emacs-mastodon")
- (version "1.0.18")
+ (version "1.0.19")
(source
(origin
(method git-fetch)
@@ -33829,7 +33862,7 @@ time.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1l4arid01m5475wq4sy8j598ww13847sbpg9grl71r72rs83071w"))))
+ (base32 "096zsjlqx2cv4zq607f9n7mr60d5avhfczf3nxsa8wkjsj97qrlh"))))
(build-system emacs-build-system)
(arguments
(list
@@ -36269,20 +36302,20 @@ state to and restoring it from a file, with auto-saving and backups.")
(define-public emacs-company-emoji
(package
(name "emacs-company-emoji")
- (version "2.8.0")
+ (version "3.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/dunn/company-emoji/")
+ (url "https://codeberg.org/egirl/company-emoji")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0j35z7hjcg3dkwgd7mdx1yaxcmxkn00h91y9kl8qdci7m4lja460"))))
+ (base32 "1afy2f1ymzr518npbhy5296kaqshax5hs2ij7wgl28h0hsa2mnk1"))))
(build-system emacs-build-system)
(propagated-inputs
(list emacs-company))
- (home-page "https://github.com/dunn/company-emoji/")
+ (home-page "https://codeberg.org/egirl/company-emoji")
(synopsis "Company completion back-end for emoji")
(description
"This library is a Company back-end providing auto-completion for
@@ -37988,7 +38021,11 @@ released, and track their progress in watching a series.")
;; Disable tests that need network access.
(substitute* (list "tests/unit/test-webpaste-provider-creation.el"
"tests/integration/test-webpaste-providers.el")
- (("describe") "xdescribe")))))))
+ (("describe") "xdescribe"))
+ (emacs-batch-edit-file "tests/integration/test-webpaste-providers.el"
+ '(progn
+ (insert ";;; -*-lexical-binding:t -*-\n")
+ (basic-save-buffer))))))))
(native-inputs
(list emacs-buttercup))
(propagated-inputs
@@ -38824,8 +38861,8 @@ headlines, keywords, tables and source blocks.")
(license license:gpl3+)))) ; License is in pyimport.el
(define-public emacs-straight-el
- (let ((commit "039e5c9a9b5c00749602afb41341e9e77ba09429")
- (revision "2"))
+ (let ((commit "b3760f5829dba37e855add7323304561eb57a3d4")
+ (revision "3"))
(package
(name "emacs-straight-el")
(version (git-version "0" revision commit))
@@ -38838,7 +38875,7 @@ headlines, keywords, tables and source blocks.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "05avzakgkwzrj1pxa1pkcv96knqq4mnkv2cszn4cs4kmvr2mchxm"))))
+ (base32 "10kvm2gzn7yf2wkfprq7cm6m2la83rdi394rcrsxql3yyhd0v599"))))
(build-system emacs-build-system)
(arguments
(list
@@ -38858,12 +38895,7 @@ headlines, keywords, tables and source blocks.")
(("\"git\"")
(string-append "\""
(search-input-file inputs "/bin/git")
- "\"")))))
- (add-after 'check 'delete-tests
- ;; "tests" directory includes bogus ".el" files that can make
- ;; `patch-el-files' phase fail.
- (lambda _
- (delete-file-recursively "tests"))))))
+ "\""))))))))
(native-inputs
(list texinfo))
(inputs