aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm114
1 files changed, 60 insertions, 54 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index eb092808f6..6083ed780b 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019, 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
@@ -52,7 +52,7 @@
;; Note - when changing Docker versions it is important to update the versions
;; of several associated packages (docker-libnetwork and go-sctp).
-(define %docker-version "19.03.13")
+(define %docker-version "19.03.15")
(define-public python-docker
(package
@@ -177,60 +177,64 @@ Python without keeping their credentials in a Docker configuration file.")
(define-public containerd
(package
(name "containerd")
- (version "1.2.5")
+ (version "1.4.4")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/containerd/containerd")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0npbzixf3c0jvzm159vygvkydrr8h36c9sq50yv0mdinrys2bvg0"))
- (patches
- (search-patches "containerd-test-with-go1.13.patch"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/containerd/containerd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qjbfj1dw6pykxhh8zahcxlgpyjzgnrngk5vjaf34akwyan8nrxb"))))
(build-system go-build-system)
(arguments
- `(#:import-path "github.com/containerd/containerd"
- #:phases
- (modify-phases %standard-phases
- (add-after 'chdir 'patch-paths
- (lambda* (#:key inputs import-path outputs #:allow-other-keys)
- ;; TODO: Patch "socat", "unpigz".
- (with-directory-excursion (string-append "src/" import-path)
- (substitute* "./runtime/v1/linux/runtime.go"
- (("defaultRuntime[ \t]*=.*")
- (string-append "defaultRuntime = \""
- (assoc-ref inputs "runc")
- "/sbin/runc\"\n"))
- (("defaultShim[ \t]*=.*")
- (string-append "defaultShim = \""
- (assoc-ref outputs "out")
- "/bin/containerd-shim\"\n")))
- (substitute* "./vendor/github.com/containerd/go-runc/runc.go"
- (("DefaultCommand[ \t]*=.*")
- (string-append "DefaultCommand = \""
- (assoc-ref inputs "runc")
- "/sbin/runc\"\n")))
- (substitute* "vendor/github.com/containerd/continuity/testutil/loopback/loopback_linux.go"
- (("exec\\.Command\\(\"losetup\"") ; )
- (string-append "exec.Command(\""
- (assoc-ref inputs "util-linux")
- "/sbin/losetup\""))) ;)
- #t)))
- (replace 'build
- (lambda* (#:key import-path (make-flags '()) #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (apply invoke "make" make-flags))))
- (replace 'install
- (lambda* (#:key import-path outputs (make-flags '()) #:allow-other-keys)
- (with-directory-excursion (string-append "src/" import-path)
- (let* ((out (assoc-ref outputs "out")))
- (apply invoke "make" (string-append "DESTDIR=" out) "install"
- make-flags))))))))
+ (let ((make-flags (list (string-append "VERSION=" version)
+ "REVISION=0")))
+ `(#:import-path "github.com/containerd/containerd"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'chdir 'patch-paths
+ (lambda* (#:key inputs import-path outputs #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* "runtime/v1/linux/runtime.go"
+ (("defaultRuntime[ \t]*=.*")
+ (string-append "defaultRuntime = \""
+ (assoc-ref inputs "runc")
+ "/sbin/runc\"\n"))
+ (("defaultShim[ \t]*=.*")
+ (string-append "defaultShim = \""
+ (assoc-ref outputs "out")
+ "/bin/containerd-shim\"\n")))
+ (substitute* "vendor/github.com/containerd/go-runc/runc.go"
+ (("DefaultCommand[ \t]*=.*")
+ (string-append "DefaultCommand = \""
+ (assoc-ref inputs "runc")
+ "/sbin/runc\"\n")))
+ (substitute* "vendor/github.com/containerd/continuity/testutil\
+/loopback/loopback_linux.go"
+ (("exec\\.Command\\(\"losetup\"")
+ (string-append "exec.Command(\""
+ (assoc-ref inputs "util-linux")
+ "/sbin/losetup\"")))
+ (substitute* "archive/compression/compression.go"
+ (("exec\\.LookPath\\(\"unpigz\"\\)")
+ (string-append "\"" (assoc-ref inputs "pigz")
+ "/bin/unpigz\", error(nil)"))))))
+ (replace 'build
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (apply invoke "make" ',make-flags))))
+ (replace 'install
+ (lambda* (#:key import-path outputs #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (let* ((out (assoc-ref outputs "out")))
+ (apply invoke "make" (string-append "DESTDIR=" out) "install"
+ ',make-flags)))))))))
(inputs
`(("btrfs-progs" ,btrfs-progs)
("libseccomp" ,libseccomp)
+ ("pigz" ,pigz)
("runc" ,runc)
("util-linux" ,util-linux)))
(native-inputs
@@ -252,7 +256,7 @@ network attachments.")
;; 'hack/dockerfile/install/proxy.installer'. NOTE - It is important that
;; this version is kept in sync with the version of Docker being used.
;; This commit is the "bump_19.03" branch, as mentioned in Docker's vendor.conf.
- (let ((commit "026aabaa659832804b01754aaadd2c0f420c68b6")
+ (let ((commit "55e924b8a84231a065879156c0de95aefc5f5435")
(version (version-major+minor %docker-version))
(revision "1"))
(package
@@ -267,7 +271,7 @@ network attachments.")
(file-name (git-file-name name version))
(sha256
(base32
- "0bli21vn5v7bssw3ydym4jfdjsldhb47fld88kng7d138wl70lkw"))
+ "19syb3scwiykn44gqfaqrgqv8a0df4ps0ykf3za9xkjc5cyi99mp"))
;; Delete bundled ("vendored") free software source code.
(modules '((guix build utils)))
(snippet '(begin
@@ -316,11 +320,11 @@ built-in registry server of Docker.")
(origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/docker/engine")
+ (url "https://github.com/moby/moby")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mg3jjisdbqrqrrhyslj3715lslial2kcgjrpprb6q63i52963gj"))
+ (base32 "0419iha9zmwlhzhnbfxlsa13vgd04yifnsr8qqnj2ks5dxrcajl8"))
(patches
(search-patches "docker-fix-tests.patch"))))
(build-system gnu-build-system)
@@ -517,6 +521,8 @@ built-in registry server of Docker.")
(delete-file "runconfig/config_test.go")
;; This file uses /var.
(delete-file "daemon/oci_linux_test.go")
+ ;; Signal tests fail in bizarre ways
+ (delete-file "pkg/signal/signal_linux_test.go")
#t))
(replace 'configure
(lambda _
@@ -611,7 +617,7 @@ provisioning etc.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0wm5x8b8jll78h2zzncfdpxj0y3gv571z0nd39f036wsy7r23dsi"))))
+ (base32 "1asapjj8brvbkd5irgdq82fx1ihrc14qaq30jxvjwflfm5yb7lv0"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/docker/cli"