aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 16b622b5f2..b8c4c7bd39 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021 Jacob Hrbek <kreyren@rixotstudio.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18084,7 +18085,7 @@ Atom, RSS 2.0, RSS 1.0, RSS 0.x and JSON Feed")
(home-page "https://gitlab.com/news-flash/fever_api")
(synopsis "Rust implementation of the Fever API")
(description
- "This packages provides a Rust implementation of the Fever API.")
+ "This package provides a Rust implementation of the Fever API.")
;; No copyright headers in the source code. LICENSE indicates gpl3.
(license license:gpl3)))
@@ -63136,3 +63137,27 @@ variant of this library is available separately as @code{im}.")
(description
"Generate Rust register maps (`struct`s) from SVD files")
(license (list license:expat license:asl2.0))))
+
+(define-public rust-shell2batch-0.4
+ (package
+ (name "rust-shell2batch")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "shell2batch" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0r9zfhxmqnrnyk7g590333szfpsjijs2wfwy7ish240w6pp54nhq"))
+ ;; https://github.com/sagiegurari/shell2batch/issues/17
+ (patches (search-patches "rust-shell2batch-lint-fix.patch"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-regex" ,rust-regex-1))))
+ (home-page "https://github.com/sagiegurari/shell2batch")
+ (synopsis "Basic shell scripts to windows batch scripts conversion")
+ (description "While it is not really possible to take every shell script
+and automatically convert it to a windows batch file, this library provides a
+way to convert simple shell commands to windows batch commands.")
+ (license license:asl2.0)))