aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm63
1 files changed, 49 insertions, 14 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index c004aade73..d13b62b5e2 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
-;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023, 2024 Foundation Devices, Inc. <hello@foundation.xyz>
;;; Copyright © 2023, 2024 David Elsing <david.elsing@posteo.net>
;;;
;;; This file is part of GNU Guix.
@@ -245,8 +245,8 @@ standard.")
(license license:lgpl2.1+))))
(define-public tomlc99
- (let ((revision "0")
- (commit "52e9c039c5418a100605c2db1282590511fa891b"))
+ (let ((revision "1")
+ (commit "5221b3d3d66c25a1dc6f0372b4f824f1202fe398"))
(package
(name "tomlc99")
(version (git-version "1.0" revision commit))
@@ -258,23 +258,36 @@ standard.")
(file-name (git-file-name name version))
(sha256
(base32
- "1zrn5mmd1ysxma96jzrq50xqypbs3rhk6dwlj1wcjpjz1a4h9wgg"))))
+ "1r443cpwy7f1f8imyfykpggkihrvv9fvdlgl95liiqmzqz9snqnd"))))
(build-system gnu-build-system)
(arguments
(list #:make-flags #~(list (string-append "CC="
#$(cc-for-target))
(string-append "prefix="
#$output))
- #:phases #~(modify-phases %standard-phases
- (delete 'configure)
- (replace 'check
- (lambda* (#:key tests? make-flags
- #:allow-other-keys)
- (when tests?
- (apply invoke
- `("make" "-C" "unittest"
- ,@make-flags))
- (invoke "./unittest/t1")))))))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'check
+ (lambda* (#:key tests? make-flags
+ #:allow-other-keys)
+ (when tests?
+ (apply invoke
+ `("make" "-C" "unittest"
+ ,@make-flags))
+ (invoke "./unittest/t1"))))
+ ;; The Makefile checks for libtoml.pc and only installs if
+ ;; the prefix is /usr/local.
+ (add-after 'install 'install-pkg-config
+ (lambda _
+ (rename-file "libtoml.pc.sample" "libtoml.pc")
+ (substitute* "libtoml.pc"
+ (("^prefix=.*")
+ (string-append "prefix=" #$output "\n")))
+
+ (let ((pc (string-append #$output "/lib/pkgconfig")))
+ (mkdir-p pc)
+ (install-file "libtoml.pc" pc)))))))
(home-page "https://github.com/cktan/tomlc99")
(synopsis "TOML library for C")
(description
@@ -628,6 +641,28 @@ be a separate step, and tokenization rules can be written in the same way as
any other grammar rules.")
(license license:expat)))
+(define-public sfsexp
+ (package
+ (name "sfsexp")
+ (version "1.4.1")
+ (home-page "https://github.com/mjsottile/sfsexp")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03srnpc7p1j7ygd0wx9gybcxhqm50kjzkybh1xs75nwz97q3y2dq"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake libtool))
+ (synopsis "Symbolic expression library for C and C++")
+ (description
+ "sfsexp is a C/C++ library to read, parse, modify, and create symbolic
+expressions.")
+ (license license:lgpl2.1+)))
+
(define-public sparse
(package
(name "sparse")