aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioconductor.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioconductor.scm')
-rw-r--r--gnu/packages/bioconductor.scm83
1 files changed, 42 insertions, 41 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index d36d070a56..5d29a3acf2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2026,13 +2026,13 @@ microarrays.")
(define-public r-annotationdbi
(package
(name "r-annotationdbi")
- (version "1.56.1")
+ (version "1.56.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "AnnotationDbi" version))
(sha256
(base32
- "1svh5zcb7ymz463z5641l2cvzniswxasjjix2plfhqs0yqf1j9qg"))))
+ "01zwq14msbbwzxv8rgpmyr74ymvhq0vnmxkxxwd886iac5vjlgi8"))))
(properties
`((upstream-name . "AnnotationDbi")))
(build-system r-build-system)
@@ -2459,13 +2459,13 @@ analysis.")
(define-public r-chipseeker
(package
(name "r-chipseeker")
- (version "1.30.0")
+ (version "1.30.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "ChIPseeker" version))
(sha256
(base32
- "1x8px8ylc231g87rd48kmy9y36h26rldbmqjkcj4mgaldvbsj0rp"))))
+ "1nr5p1h9131rvbpnh2kizzx9q6f4ycq6rzxy1yqg2pczqcg7hy4x"))))
(build-system r-build-system)
(native-inputs
`(("r-knitr" ,r-knitr)))
@@ -2822,14 +2822,14 @@ CAGE.")
(define-public r-ensembldb
(package
(name "r-ensembldb")
- (version "2.18.0")
+ (version "2.18.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ensembldb" version))
(sha256
(base32
- "02rdbqp33g488w1df1rgp0dg63qrr6w2kmgigxzc8l9wmrvj0y1j"))))
+ "0q56gv0isa9ayw505py7i7x65pvcshmd2j1mna1wpbk66wqj4qzx"))))
(build-system r-build-system)
(propagated-inputs
`(("r-annotationdbi" ,r-annotationdbi)
@@ -3518,14 +3518,14 @@ in SNV base substitution data.")
(define-public r-msnbase
(package
(name "r-msnbase")
- (version "2.20.0")
+ (version "2.20.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "MSnbase" version))
(sha256
(base32
- "1r5igzb7xb5qcw37ffy0c3j6vlg9zffmksrc57rs1pmfnca773z5"))))
+ "0ip614mdwisz2hlmyfgngysq1s3hajb88cgdmygfc8i6kyxjkjzl"))))
(properties `((upstream-name . "MSnbase")))
(build-system r-build-system)
(propagated-inputs
@@ -4442,14 +4442,14 @@ unmodeled, or latent sources of noise.")
(define-public r-systempiper
(package
(name "r-systempiper")
- (version "2.0.0")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "systemPipeR" version))
(sha256
(base32
- "0kibr47z7ml13hpl955qcr4wp2z4nq7gjiinyk30wivrwrng5sg1"))))
+ "1r0qc1pyff9nvjix21xjd6fmka06ywr4ipr8szm52hq41hwaiqgq"))))
(properties `((upstream-name . "systemPipeR")))
(build-system r-build-system)
(propagated-inputs
@@ -5825,14 +5825,14 @@ multiplication.")
(define-public r-treeio
(package
(name "r-treeio")
- (version "1.18.0")
+ (version "1.18.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "treeio" version))
(sha256
(base32
- "03gz378qrp6b9fcriqanfnphibqv4bxhvz48rigzkidkzz71wfaj"))))
+ "19i8jhvycv57zbxhpn5gx5ymdiws64kc3nidc00xh1j9a8xkj1aq"))))
(properties `((upstream-name . "treeio")))
(build-system r-build-system)
(propagated-inputs
@@ -5857,14 +5857,14 @@ platform for merging tree with associated data and converting file formats.")
(define-public r-ggtree
(package
(name "r-ggtree")
- (version "3.2.0")
+ (version "3.2.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "ggtree" version))
(sha256
(base32
- "1c6b7kjh44k096v8mhn53abr181vpbn7s6ab7zk4phnsyfxsclxb"))))
+ "0qk39gdpy4kznjhmvi25y2spcdj2r1i6mv673vx8dzf66zfs20v8"))))
(properties `((upstream-name . "ggtree")))
(build-system r-build-system)
(propagated-inputs
@@ -6315,14 +6315,14 @@ independent of the p-value under the null hypothesis.")
(define-public r-icobra
(package
(name "r-icobra")
- (version "1.22.0")
+ (version "1.22.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "iCOBRA" version))
(sha256
(base32
- "0qg32g1rfvh6mx8wny1lrva9vc347288hzml7yb4rnrsx1hggkpa"))))
+ "05j3h314l2bw8n61h1nyiqhm3z7c1axycn4p3xkfccq5i4mcqvn2"))))
(properties `((upstream-name . "iCOBRA")))
(build-system r-build-system)
(propagated-inputs
@@ -6726,14 +6726,14 @@ high-throughput analyses.")
(define-public r-geoquery
(package
(name "r-geoquery")
- (version "2.62.0")
+ (version "2.62.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "GEOquery" version))
(sha256
(base32
- "0fkx4jh1s76l015vwikkryarlx6iihb1z935nzpdhah3rpqx3b3z"))))
+ "0plmh4x37r848g6ilvl1x8cim90rp85gikfc5m8lgi2i4xkq7hbq"))))
(properties `((upstream-name . "GEOquery")))
(build-system r-build-system)
(propagated-inputs
@@ -6743,6 +6743,7 @@ high-throughput analyses.")
("r-httr" ,r-httr)
("r-limma" ,r-limma)
("r-magrittr" ,r-magrittr)
+ ("r-r-utils" ,r-r-utils)
("r-readr" ,r-readr)
("r-tidyr" ,r-tidyr)
("r-xml2" ,r-xml2)))
@@ -9550,14 +9551,14 @@ annotations.")
(define-public r-rsubread
(package
(name "r-rsubread")
- (version "2.8.0")
+ (version "2.8.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "Rsubread" version))
(sha256
(base32
- "09kd7vl2z9k82ppfzy679hs7d00c60z3w3n6a8wq4z3k3f4glc3s"))))
+ "0lpx0dp5570kbrq7v0g573axkhi00qrf38si59vmvnqxhmkvsixn"))))
(properties `((upstream-name . "Rsubread")))
(build-system r-build-system)
(inputs `(("zlib" ,zlib)))
@@ -10113,14 +10114,14 @@ self-organizing map clustering and minimal spanning trees.")
(define-public r-mixomics
(package
(name "r-mixomics")
- (version "6.17.26")
+ (version "6.18.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "mixOmics" version))
(sha256
(base32
- "10ir4876sjmw2mw0cjvshwy3qyhsyz6g1ihyr3dycgzya0jcxw1x"))))
+ "0jwkb5scc33nfn2mibga8vp00pmc24ham71gpkbizvy43cy85icf"))))
(properties `((upstream-name . "mixOmics")))
(build-system r-build-system)
(propagated-inputs
@@ -11978,14 +11979,14 @@ gene selection, testing relationships, and so on.")
(define-public r-biocpkgtools
(package
(name "r-biocpkgtools")
- (version "1.12.0")
+ (version "1.12.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "BiocPkgTools" version))
(sha256
(base32
- "13m6h35938407ajj7fakl50g4p2wsvinkg0r2mwl1zwq88735arg"))))
+ "1yz2sgx4xrnw22k3d6q6hkj213bnbb4hbr5ymxnmjnsz551s75ny"))))
(properties `((upstream-name . "BiocPkgTools")))
(build-system r-build-system)
(propagated-inputs
@@ -12026,14 +12027,14 @@ analytics on packages.")
(define-public r-biocset
(package
(name "r-biocset")
- (version "1.8.0")
+ (version "1.8.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "BiocSet" version))
(sha256
(base32
- "0ysm68gcalg3d91jx6vmdzra01vc6kvzqnvz557g3rnm0wkx12q6"))))
+ "1x5ar9byr85iap2x6y66j31fi17wr31awx1gl3z01sckp0dldx6w"))))
(properties `((upstream-name . "BiocSet")))
(build-system r-build-system)
(propagated-inputs
@@ -12378,13 +12379,13 @@ routines.")
(define-public r-s4vectors
(package
(name "r-s4vectors")
- (version "0.32.0")
+ (version "0.32.2")
(source (origin
(method url-fetch)
(uri (bioconductor-uri "S4Vectors" version))
(sha256
(base32
- "1zm1xlqrq1f9xa81j3ij2p78g3aywq7izsk3h40z94fjggahvc09"))))
+ "0xrmii2dnwyknpjdiwwjlklgzpbk9q09br27rq5ffz08if9yyk20"))))
(properties
`((upstream-name . "S4Vectors")))
(build-system r-build-system)
@@ -12538,14 +12539,14 @@ provided.")
(define-public r-hdf5array
(package
(name "r-hdf5array")
- (version "1.22.0")
+ (version "1.22.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "HDF5Array" version))
(sha256
(base32
- "13h6qr4zkynir0ck2aiasjvlid7hrk3m2lzkjyhpvbg1a15r8zi9"))))
+ "1al4a88pgdl7hfhphsnwl1gg1c1kmw37wcdr4v4pfsw5l8ff7nx4"))))
(properties `((upstream-name . "HDF5Array")))
(build-system r-build-system)
(inputs
@@ -12963,14 +12964,14 @@ quality control.")
(define-public r-scran
(package
(name "r-scran")
- (version "1.22.0")
+ (version "1.22.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "scran" version))
(sha256
(base32
- "1nyvbss4914giwzp5wiw9g4z5b6lr5iprbjrqlg4vpgnf1hz8k7l"))))
+ "06lcxya6rpa8dv0il7m7fwyx0ci1y1jn16ff5lmvzf2mnr6q7lic"))))
(build-system r-build-system)
(propagated-inputs
`(("r-beachmat" ,r-beachmat)
@@ -13123,9 +13124,9 @@ within the R for Mass Spectrometry packages.")
"The MsFeature package defines functionality for Mass Spectrometry
features. This includes functions to group (LC-MS) features based on some of
their properties, such as retention time (coeluting features), or correlation
-of signals across samples. This package hence allows to group features, and
+of signals across samples. This package hence can be used to group features, and
its results can be used as an input for the @code{QFeatures} package which
-allows to aggregate abundance levels of features within each group. This
+allows aggregating abundance levels of features within each group. This
package defines concepts and functions for base and common data types,
implementations for more specific data types are expected to be implemented in
the respective packages (such as e.g. @code{xcms}).")
@@ -13789,14 +13790,14 @@ the earlier snpMatrix package, allowing for uncertainty in genotypes.")
(define-public r-chromstar
(package
(name "r-chromstar")
- (version "1.19.0")
+ (version "1.20.2")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "chromstaR" version))
(sha256
(base32
- "0z511l26fhz00qn8h2yybylk8c3ws8hj1hp8hq9qj9mfczwiqy3j"))))
+ "1akcmxzn4j9ph4n3lsgfh8fh8hrb28jjamz037w59bsdkcv6wyjq"))))
(properties `((upstream-name . "chromstaR")))
(build-system r-build-system)
(propagated-inputs
@@ -14008,7 +14009,7 @@ real numbers.")
(home-page "https://github.com/BgeeDB/BgeeCall")
(synopsis "RNA-Seq present/absent gene expression calls generation")
(description
- "BgeeCall allows to generate present/absent gene expression calls without
+ "BgeeCall allows generating present/absent gene expression calls without
using an arbitrary cutoff like TPM<1. Calls are generated based on reference
intergenic sequences. These sequences are generated based on expression of
all RNA-Seq libraries of each species integrated in Bgee.")
@@ -14268,14 +14269,14 @@ the Bioconductor project.")
(define-public r-biodb
(package
(name "r-biodb")
- (version "1.2.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "biodb" version))
(sha256
(base32
- "0q343zbx341xdy634p50k7bj6byv8v2rqzy50nw75a79206pajl4"))))
+ "1z4adapsnpw6fwanihdz43r11ijypxs5wbndb1i98j8kb7wf308k"))))
(properties `((upstream-name . "biodb")))
(build-system r-build-system)
(propagated-inputs
@@ -14844,14 +14845,14 @@ estimates, etc.")
(define-public r-tximeta
(package
(name "r-tximeta")
- (version "1.12.0")
+ (version "1.12.3")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "tximeta" version))
(sha256
(base32
- "03fbz6pka7bcbhd0bblgckyxsqhzp4n8qp2dcpdb3sr01lyw4bc5"))))
+ "15l1jvfis7xzxwwnlqs8xpaf212v1lx513np2dc4l4h7rqhclm2v"))))
(properties `((upstream-name . "tximeta")))
(build-system r-build-system)
(propagated-inputs