aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/android.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/android.scm')
-rw-r--r--gnu/packages/android.scm35
1 files changed, 33 insertions, 2 deletions
diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 32c295f9e4..902bc31faf 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -36,6 +36,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system android-ndk)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system python)
@@ -1224,6 +1225,36 @@ connected devices via ADB.")
(home-page "https://github.com/mvdan/fdroidcl")
(license license:bsd-3)))
+(define-public emacs-fdroid
+ (package
+ (name "emacs-fdroid")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/migalmoreno/fdroid.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gv4kfir12bbi17cm5hpx197m8dbw1xwqp0z6qb3vc0fdnyis35j"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-name
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "fdroid.el"
+ ("fdroid-program"
+ (search-input-file inputs "/bin/fdroidcl"))))))))
+ (inputs (list fdroidcl))
+ (home-page "https://github.com/migalmoreno/fdroid.el")
+ (synopsis "Manage F-Droid packages from Emacs")
+ (description "This package is an Emacs interface to F-Droid. Its purpose
+is to aid in the management of F-Droid packages for an Android device or an
+emulator inside the comfort of Emacs.")
+ (license license:gpl3+)))
+
(define-public enjarify
(package
(name "enjarify")
@@ -1277,7 +1308,7 @@ Java bytecode, which simplifies the analysis of Android applications.")
(define-public android-file-transfer
(package
(name "android-file-transfer")
- (version "4.2")
+ (version "4.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1287,7 +1318,7 @@ Java bytecode, which simplifies the analysis of Android applications.")
(file-name (git-file-name name version))
(sha256
(base32
- "125rq8ji83nw6chfw43i0h9c38hjqh1qjibb0gnf9wrigar9zc8b"))))
+ "1ianph8ivj0fxg1l7llid7gv4pbfb5j23b33j9gan6x7scr13q2h"))))
(build-system cmake-build-system)
(arguments
(list #:tests? #f)) ;there are no tests