aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/graphviz.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 0fc5c6024e..18f4fc147d 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -314,9 +314,12 @@ Graphviz and LaTeX.")
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
+ (graphviz (assoc-ref inputs "graphviz"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(python-path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/bin/xdot")
+ `("PATH" ":" prefix
+ (,(string-append graphviz "/bin")))
`("GI_TYPELIB_PATH" ":" prefix
(,gi-typelib-path))
`("GUIX_PYTHONPATH" ":" prefix