aboutsummaryrefslogtreecommitdiff
path: root/doc/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'doc/local.mk')
-rw-r--r--doc/local.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 97122c737d..53f41f1c87 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -100,7 +100,7 @@ cat "$@.tmp" | egrep '@p?x?ref' -A1 | sed 'N;s|--\n||g;P;D' | sed 's|^| |g' | \
line=$$(grep -n "^msgid \"$$e\"" "$<" | cut -f1 --delimiter=":") ;\
((line++)) ;\
if [ "$$line" != "1" ]; then \
- translation=$$(head -n "$$line" "$<" | tail -1 | grep msgstr | sed 's|msgstr "\(.*\)"|\1|') ;\
+ translation=$$(head -n "$$line" "$<" | tail -1 | grep msgstr | sed 's|msgstr "\([^"]*\)"|\1|') ;\
if [ "$$translation" != "" ]; then \
sed "N;s@\(p\?x\?ref\){$$(echo $$e | sed 's| |[\\n ]|g')\(,\|}\)@\1{$$translation\2@g;P;D" -i "$@.tmp" ;\
fi ;\