aboutsummaryrefslogtreecommitdiff
path: root/doc/local.mk
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-04-18 04:51:49 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-04-18 13:17:09 +0200
commit0571edc179fd2ba8edd603487c808717d6733604 (patch)
tree3d8fc9de496f24cb6903b410d48e33af7b5264c4 /doc/local.mk
parent9f2da0a0613f864aed9002950f4eaac59ae89d77 (diff)
downloadguix-0571edc179fd2ba8edd603487c808717d6733604.tar
guix-0571edc179fd2ba8edd603487c808717d6733604.tar.gz
doc: Fix pxref translation issue.
* doc/local.mk (xref_command): Change regexp to match properly.
Diffstat (limited to 'doc/local.mk')
-rw-r--r--doc/local.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 97122c737d..53f41f1c87 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -100,7 +100,7 @@ cat "$@.tmp" | egrep '@p?x?ref' -A1 | sed 'N;s|--\n||g;P;D' | sed 's|^| |g' | \
line=$$(grep -n "^msgid \"$$e\"" "$<" | cut -f1 --delimiter=":") ;\
((line++)) ;\
if [ "$$line" != "1" ]; then \
- translation=$$(head -n "$$line" "$<" | tail -1 | grep msgstr | sed 's|msgstr "\(.*\)"|\1|') ;\
+ translation=$$(head -n "$$line" "$<" | tail -1 | grep msgstr | sed 's|msgstr "\([^"]*\)"|\1|') ;\
if [ "$$translation" != "" ]; then \
sed "N;s@\(p\?x\?ref\){$$(echo $$e | sed 's| |[\\n ]|g')\(,\|}\)@\1{$$translation\2@g;P;D" -i "$@.tmp" ;\
fi ;\