aboutsummaryrefslogtreecommitdiff
path: root/doc/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'doc/local.mk')
-rw-r--r--doc/local.mk32
1 files changed, 0 insertions, 32 deletions
diff --git a/doc/local.mk b/doc/local.mk
index 130f40ece9..1d94e3c758 100644
--- a/doc/local.mk
+++ b/doc/local.mk
@@ -260,38 +260,6 @@ endif
# Reproducible tarball
-# Define a rule to build `version[LANG].texi' reproducibly using metadata from
-# Git rather than using metadata from the filesystem.
-define version.texi-from-git
-$(srcdir)/doc/stamp-$(1): $(srcdir)/$(2) $(top_srcdir)/configure
- $$(AM_V_GEN)set -e; \
- export LANG=C LANGUAGE=C LC_ALL=C LC_TIME=C; \
- export TZ=UTC0; \
- timestamp="$$$$(git log --pretty=format:%ct -n1 -- "$$<" \
- 2>/dev/null \
- || echo $$(SOURCE_DATE_EPOCH))" \
- dmy=$$$$(date --date="@$$$$timestamp" "+%-d %B %Y"); \
- my=$$$$(date --date="@$$$$timestamp" "+%B %Y"); \
- { echo "@set UPDATED $$$$dmy"; \
- echo "@set UPDATED-MONTH $$$$my"; \
- echo "@set EDITION $$$(VERSION)"; \
- echo "@set VERSION $$$(VERSION)"; } > "$$@-t"; \
- mv "$$@-t" "$$@"; \
- cp -p "$$@" "$$(srcdir)/doc/version$(3).texi"
-endef
-
-# Generate rules for stamp-vti and stamp-N that create version.texi and
-# version-LANG.texi to override the Autotools versions that use timestamps
-# embedded in the file-system. These are expected to generate warnings:
-#
-# Makefile:7376: warning: overriding recipe for target 'doc/stamp-vti'
-# Makefile:5098: warning: ignoring old recipe for target 'doc/stamp-vti'
-i:=0
-$(eval $(call version.texi-from-git,vti,doc/guix.texi,))
-$(foreach lang, $(MANUAL_LANGUAGES), \
- $(eval i=$(shell echo $$(($(i)+1)))) \
- $(eval $(call version.texi-from-git,$(i),po/doc/guix-manual.$(lang).po,-$(lang))))
-
DIST_CONFIGURE_FLAGS = \
--localstatedir=/var \
--sysconfdir=/etc