aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 1 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b866e91b2c..b34f15a77b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -160,18 +160,11 @@ AC_ARG_WITH([nix-prefix],
esac],
[])
-AC_PATH_PROG([NIX_INSTANTIATE], [nix-instantiate])
AC_PATH_PROG([NIX_HASH], [nix-hash])
-if test "x$guix_build_daemon$NIX_INSTANTIATE$NIX_HASH" = "xno"; then
+if test "x$guix_build_daemon$NIX_HASH" = "xno"; then
AC_MSG_ERROR([Nix programs not found; please install Nix or use `--with-nix-prefix'.])
fi
-if test "x$NIX_INSTANTIATE" = "x"; then
- # This program is an optional dependency, so we just want it to be
- # taken from $PATH if it's not available right now.
- NIX_INSTANTIATE="nix-instantiate"
-fi
-
AC_ARG_WITH([nixpkgs],
[AS_HELP_STRING([--with-nixpkgs=DIR],
[search for Nixpkgs in DIR (for testing purposes only)])],