aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/Makefile.am b/Makefile.am
index 0267e8fe50..f4cdba94a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -262,11 +262,7 @@ STORE_MODULES = \
guix/store/database.scm \
guix/store/deduplication.scm
-if HAVE_GUILE_SQLITE3
MODULES += $(STORE_MODULES)
-else
-MODULES_NOT_COMPILED += $(STORE_MODULES)
-endif !HAVE_GUILE_SQLITE3
# Internal modules with test suite support.
dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
@@ -379,7 +375,9 @@ SCM_TESTS = \
tests/scripts-build.scm \
tests/containers.scm \
tests/pack.scm \
- tests/import-utils.scm
+ tests/import-utils.scm \
+ tests/store-database.scm \
+ tests/store-deduplication.scm
if HAVE_GUILE_JSON
@@ -391,14 +389,6 @@ SCM_TESTS += \
endif
-if HAVE_GUILE_SQLITE3
-
-SCM_TESTS += \
- tests/store-database.scm \
- tests/store-deduplication.scm
-
-endif
-
SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \