aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/fabric-management.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/fabric-management.scm b/gnu/packages/fabric-management.scm
index 09e4a2b854..dc32b163da 100644
--- a/gnu/packages/fabric-management.scm
+++ b/gnu/packages/fabric-management.scm
@@ -164,10 +164,12 @@ interface to this library is not guaranteed to be stable.")
perl))
(native-inputs (list swig))
(arguments
- `(#:configure-flags
- (list (string-append "--with-osm=" (assoc-ref %build-inputs "opensm"))
- (string-append "--with-tk-lib=" (assoc-ref %build-inputs "tk") "/lib")
- "--disable-static")))
+ (list #:configure-flags
+ #~(list (string-append "--with-osm="
+ #$(this-package-input "opensm"))
+ (string-append "--with-tk-lib="
+ #$(this-package-input "tk") "/lib")
+ "--disable-static")))
(synopsis "InfiniBand network utilities")
(description "These command-line utilities allow for diagnosing and
testing InfiniBand networks.")