aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/game-development.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 7eac935a69..bb4c1d26bb 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -314,6 +314,16 @@ provide connectivity for client applications written in any language.")
(base32
"1pmvvm3sgnpngfa7884mqhq3fwdjh9sr0ca07ypnidcg0y341w53"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'fix-pillow
+ (lambda _
+ ;; pillow's version is not in PIL.Image.VERSION anymore
+ (substitute* "nml/version_info.py"
+ (("from PIL import Image") "import PIL")
+ (("Image.VERSION") "PIL.__version__"))
+ #t)))))
(propagated-inputs
`(("python-pillow" ,python-pillow)
("python-ply" ,python-ply)))