aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/guix.texi6
-rw-r--r--gnu/packages.scm17
-rw-r--r--tests/guix-build.sh1
3 files changed, 5 insertions, 19 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 9f63413bbf..9b2fe3fdb8 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -16281,9 +16281,9 @@ distribution:
@smallexample
$ guix lint -c cve
-gnu/packages/base.scm:652:2: glibc-2.21: probably vulnerable to CVE-2015-1781, CVE-2015-7547
-gnu/packages/gcc.scm:334:2: gcc-4.9.3: probably vulnerable to CVE-2015-5276
-gnu/packages/image.scm:312:2: openjpeg-2.1.0: probably vulnerable to CVE-2016-1923, CVE-2016-1924
+gnu/packages/base.scm:652:2: glibc@@2.21: probably vulnerable to CVE-2015-1781, CVE-2015-7547
+gnu/packages/gcc.scm:334:2: gcc@@4.9.3: probably vulnerable to CVE-2015-5276
+gnu/packages/image.scm:312:2: openjpeg@@2.1.0: probably vulnerable to CVE-2016-1923, CVE-2016-1924
@dots{}
@end smallexample
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 92bab7228a..bec8163b2b 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -306,7 +306,7 @@ return its return value."
;;; Package specification.
;;;
-(define* (%find-package spec name version #:key fallback?)
+(define* (%find-package spec name version)
(match (find-best-packages-by-name name version)
((pkg . pkg*)
(unless (null? pkg*)
@@ -314,10 +314,6 @@ return its return value."
(warning (_ "choosing ~a@~a from ~a~%")
(package-name pkg) (package-version pkg)
(location->string (package-location pkg))))
- (when fallback?
- (warning (_ "deprecated NAME-VERSION syntax; \
-use NAME@VERSION instead~%")))
-
(match (package-superseded pkg)
((? package? new)
(info (_ "package '~a' has been superseded by '~a'~%")
@@ -328,16 +324,7 @@ use NAME@VERSION instead~%")))
(x
(if version
(leave (_ "~A: package not found for version ~a~%") name version)
- (if (not fallback?)
- ;; XXX: Fallback to the older specification style with an hyphen
- ;; between NAME and VERSION, for backward compatibility.
- (call-with-values
- (lambda ()
- (hyphen-separated-name->name+version name))
- (cut %find-package spec <> <> #:fallback? #t))
-
- ;; The fallback case didn't find anything either, so bail out.
- (leave (_ "~A: unknown package~%") name))))))
+ (leave (_ "~A: unknown package~%") name)))))
(define (specification->package spec)
"Return a package matching SPEC. SPEC may be a package name, or a package
diff --git a/tests/guix-build.sh b/tests/guix-build.sh
index 9494e7371f..880a582777 100644
--- a/tests/guix-build.sh
+++ b/tests/guix-build.sh
@@ -185,7 +185,6 @@ test "`guix build superseded -d`" = "`guix build bar -d`"
# Parsing package names and versions.
guix build -n time # PASS
guix build -n time@1.7 # PASS, version found
-guix build -n time-1.7 # PASS, deprecated version syntax
if guix build -n time@3.2; # FAIL, version not found
then false; else true; fi
if guix build -n something-that-will-never-exist; # FAIL