aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 85c07605ca..66fa69fade 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2384,6 +2384,65 @@ Methodologies included in the @code{ANCOMBC} package were designed to correct
these biases and construct statistically consistent estimators.")
(license license:artistic2.0)))
+(define-public r-animalcules
+ (package
+ (name "r-animalcules")
+ (version "1.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "animalcules" version))
+ (sha256
+ (base32
+ "1alpsamrglgvzhcibkaf7m3gyiv61wbj1gvsq4lw6vjka100j9qr"))))
+ (properties `((upstream-name . "animalcules")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-ape
+ r-assertthat
+ r-biomformat
+ r-caret
+ r-covr
+ r-deseq2
+ r-dplyr
+ r-dt
+ r-forcats
+ r-ggplot2
+ r-glmnet
+ r-gunifrac
+ r-lattice
+ r-limma
+ r-magrittr
+ r-matrix
+ r-multiassayexperiment
+ r-plotly
+ r-plotroc
+ r-rentrez
+ r-reshape2
+ r-s4vectors
+ r-scales
+ r-shiny
+ r-shinyjs
+ r-summarizedexperiment
+ r-tibble
+ r-tsne
+ r-umap
+ r-vegan
+ r-xml))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/compbiomed/animalcules")
+ (synopsis "Interactive microbiome analysis toolkit")
+ (description
+ "Animalcules is an R package for utilizing up-to-date data analytics,
+visualization methods, and machine learning models to provide users an
+easy-to-use interactive microbiome analysis framework. It can be used as a
+standalone software package or users can explore their data with the
+accompanying interactive R Shiny application. Traditional microbiome analysis
+such as alpha/beta diversity and differential abundance analysis are enhanced,
+while new methods like biomarker identification are introduced by animalcules.
+Powerful interactive and dynamic figures generated by animalcules enable users
+to understand their data better and discover new insights.")
+ (license license:artistic2.0)))
+
(define-public r-aldex2
(package
(name "r-aldex2")