aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--build-aux/hydra/demo-os.scm4
-rw-r--r--gnu/packages/gawk.scm2
-rw-r--r--gnu/packages/guile.scm30
-rw-r--r--gnu/packages/python.scm2
-rw-r--r--guix/build-system/gnu.scm4
-rw-r--r--guix/build/gnu-build-system.scm2
-rw-r--r--guix/packages.scm2
-rw-r--r--guix/profiles.scm2
8 files changed, 20 insertions, 28 deletions
diff --git a/build-aux/hydra/demo-os.scm b/build-aux/hydra/demo-os.scm
index 95950cacb1..ce46caa580 100644
--- a/build-aux/hydra/demo-os.scm
+++ b/build-aux/hydra/demo-os.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,7 +29,7 @@
(operating-system
(host-name "gnu")
(timezone "Europe/Paris")
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(bootloader (grub-configuration
(device "/dev/sda")))
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index fa07f5bd4b..425974f61e 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -66,7 +66,7 @@
(setenv "GUIX_LOCPATH" (getcwd))
(zero? (system* "localedef" "--no-archive"
"--prefix" (getcwd) "-i" "en_US"
- "-f" "UTF-8" "./en_US.UTF-8")))
+ "-f" "UTF-8" "./en_US.utf8")))
%standard-phases))))
(inputs `(("libsigsegv" ,libsigsegv)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index d5a95a0444..f77c9dfece 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -295,25 +295,17 @@ many readers as needed).")
(string-append "--with-guilesitedir="
(assoc-ref %outputs "out")
"/share/guile/site/2.0"))
- #:phases (alist-cons-before
- 'check 'change-locale
- (lambda _
- ;; Use the locale that's actually available in the build
- ;; environment.
- (substitute* "test/f009_form_wide.test"
- (("en_US\\.utf8")
- "en_US.UTF-8")))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/share/guile/site/"))
- (files (find-files dir ".scm")))
- (substitute* files
- (("\"libguile-ncurses\"")
- (format #f "\"~a/lib/libguile-ncurses\""
- out)))))
- %standard-phases))))
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dir (string-append out "/share/guile/site/"))
+ (files (find-files dir ".scm")))
+ (substitute* files
+ (("\"libguile-ncurses\"")
+ (format #f "\"~a/lib/libguile-ncurses\""
+ out)))))
+ %standard-phases)))
(home-page "http://www.gnu.org/software/guile-ncurses/")
(synopsis "Guile bindings to ncurses")
(description
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 708ba29d24..fd1a2d3601 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3665,7 +3665,7 @@ cluster without needing to write any wrapper code yourself.")
(man1 (string-append data "/man/man1"))
(info (string-append data "/info"))
(examples (string-append doc "/examples")))
- (setenv "LANG" "en_US.UTF-8")
+ (setenv "LANG" "en_US.utf8")
(with-directory-excursion "docs"
;; FIXME: html and pdf fail to build
;; (system* "make" "html")
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 1f302447c2..3be83468eb 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -287,7 +287,7 @@ standard packages used as implicit inputs of the GNU build system."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)
@@ -422,7 +422,7 @@ is one of `host' or `target'."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 75439c8330..ff7646b22c 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -99,7 +99,7 @@
#t)
(define* (install-locale #:key
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(locale-category LC_ALL)
#:allow-other-keys)
"Try to install LOCALE; emit a warning if that fails. The main goal is to
diff --git a/guix/packages.scm b/guix/packages.scm
index 72822b8c97..622cb0ac0c 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -478,7 +478,7 @@ IMPORTED-MODULES specify modules to use/import for use by SNIPPET."
;; First of all, install a UTF-8 locale so that UTF-8 file names
;; are correctly interpreted. During bootstrap, LOCALES is #f.
(setenv "LOCPATH" (string-append #+locales "/lib/locale"))
- (setlocale LC_ALL "en_US.UTF-8"))
+ (setlocale LC_ALL "en_US.utf8"))
(setenv "PATH" (string-append #+xz "/bin" ":"
#+decomp "/bin"))
diff --git a/guix/profiles.scm b/guix/profiles.scm
index c56ebb145b..fac322bbab 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -576,7 +576,7 @@ MANIFEST. Single-file bundles are required by programs such as Git and Lynx."
(setenv "LOCPATH"
(string-append #+glibc-utf8-locales "/lib/locale/"
#+(package-version glibc-utf8-locales)))
- (setlocale LC_ALL "en_US.UTF-8")
+ (setlocale LC_ALL "en_US.utf8")
(match (append-map ca-files '#$(manifest-inputs manifest))
(()