aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm2
-rw-r--r--gnu/packages/efi.scm4
-rw-r--r--gnu/packages/guile.scm8
-rw-r--r--gnu/packages/image.scm3
-rw-r--r--gnu/packages/kde.scm3
-rw-r--r--gnu/packages/linphone.scm3
-rw-r--r--gnu/packages/maths.scm4
-rw-r--r--gnu/packages/mpi.scm2
-rw-r--r--gnu/packages/music.scm7
-rw-r--r--gnu/packages/perl.scm6
-rw-r--r--gnu/packages/tryton.scm3
-rw-r--r--gnu/packages/video.scm3
-rw-r--r--tests/graph.scm2
13 files changed, 1 insertions, 49 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f7adca0860..99cc056f9f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3521,8 +3521,6 @@ annotations of the genome.")
;; remainder of the code is licensed under the MIT license.
(license (list license:bsd-3 license:expat))))
-(define-deprecated deeptools python-deeptools)
-
(define-public cutadapt
(package
(name "cutadapt")
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 4625538d26..75eb24bf86 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -96,10 +96,6 @@ environment presented by Intel's EFI.")
information.")
(license license:bsd-2))))
-(define-public efi_analyzer
- ;; For a short while the package name contained an underscore.
- (deprecated-package "efi_analyzer" efi-analyzer))
-
(define-public sbsigntools
(package
(name "sbsigntools")
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index b6db506140..dc2c42cdc9 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -291,8 +291,6 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-deprecated guile-2.2/bug-fix guile-2.2)
-
(define-public guile-2.2.4
(package
(inherit guile-2.2)
@@ -652,12 +650,6 @@ specification. These are the main features:
;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
(license license:gpl3+)))
-;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
-;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
-;; 'guile-json-3'.
-(define-deprecated guile-json guile-json-1)
-(export guile-json)
-
(define-public guile2.0-json
(package-for-guile-2.0 guile-json-1))
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0da990e63a..a236ff7e9a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1744,9 +1744,6 @@ and decompress to 32-bit and big-endian pixel buffers (RGBX, XBGR, etc.).")
license:ijg ;the libjpeg library and associated tools
license:zlib)))) ;the libjpeg-turbo SIMD extensions
-(define-deprecated libjpeg libjpeg-turbo)
-(export libjpeg)
-
(define-public niftilib
(package
(name "niftilib")
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 8a69ef5bad..f9c0a260f0 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -412,9 +412,6 @@ software (Git, Subversion, Mercurial, CVS and Bazaar).")
for some KDevelop language plugins (Ruby, PHP, CSS...).")
(license license:lgpl2.0+)))
-;; kdevplatform was merged into kdevelop as of 5.2.x
-(define-deprecated kdevplatform kdevelop)
-
(define-public kdiagram
(package
(name "kdiagram")
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index 84bc16805c..d41d368e67 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -876,9 +876,6 @@ and video calls or instant messaging capabilities to an application.")
(home-page "https://linphone.org/technical-corner/linphone")
(license license:gpl3+)))
-(define-public linphoneqt
- (deprecated-package "linphoneqt" linphone-desktop))
-
(define-public msopenh264
(let ((commit "88697cc95140017760d6da408cb0efdc5e86e40a")
(revision "0"))
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4449de94b1..c10fc8075c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4776,10 +4776,6 @@ it also includes a BLAS compatibility layer which gives application developers
access to BLIS implementations via traditional BLAS routine calls.")
(license license:bsd-3)))
-(define-public blis-sandybridge (deprecated-package "blis-sandybridge" blis))
-(define-public blis-haswell (deprecated-package "blis-haswell" blis))
-(define-public blis-knl (deprecated-package "blis-knl" blis))
-
(define ignorance blis)
(define-public openlibm
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 6faa47c669..f21bd16d3a 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -177,8 +177,6 @@ bind processes, and much more.")
(("hwloc_topology_init" all)
(string-append "exit (77);\n" all)))))))))))
-(define-deprecated hwloc-2.0 hwloc-2)
-
(define-public hwloc
;; The latest stable series of hwloc.
hwloc-2)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c63dc69972..bdf30c67a1 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1609,9 +1609,6 @@ Because Abjad wraps the LilyPond music notation package, you can use Abjad to co
typographic detail of symbols on the page.")
(license license:expat)))
-(define-public python-abjad
- (deprecated-package "python-abjad" abjad))
-
(define-public abjad-ext-rmakers
(package
(name "abjad-ext-rmakers")
@@ -6577,10 +6574,6 @@ to be bundled with the Zrythm @dfn{digital audio workstation} (DAW).")
(home-page "https://www.zrythm.org/en/plugins.html")
(license license:agpl3+)))
-(define-public zlfo
- ;; The "zlfo" package is now included in zplugins
- (deprecated-package "zlfo" zplugins))
-
(define-public remid-lv2
(package
(name "remid-lv2")
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index cc92b7af80..64089f9dd3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -843,9 +843,6 @@ error when it would have happened.")
(description "This module disables bareword filehandles.")
(license (package-license perl))))
-(define-public perl-base
- (deprecated-package "perl-base" perl))
-
(define-public perl-browser-open
(package
(name "perl-browser-open")
@@ -8694,9 +8691,6 @@ distributions.")
libraries from which Perl modules can be loaded.")
(license license:perl-license)))
-(define-public perl-parent
- (deprecated-package "perl-parent" perl))
-
(define-public perl-path-class
(package
(name "perl-path-class")
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8e561cad45..0b367675ae 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -100,9 +100,6 @@ core base of a complete business solution providing modularity, scalability
and security.")
(license license:gpl3+)))
-(define-public python-trytond
- (deprecated-package "python-trytond" trytond))
-
(define-public tryton
(package
(name "tryton")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 47b5fd1593..98684c56e1 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2353,9 +2353,6 @@ can use youtube-dl or yt-dlp packages to download videos, the focus is more on
images and image hosting sites.")
(license license:gpl2)))
-(define-public gnome-mpv
- (deprecated-package "gnome-mpv" celluloid))
-
(define-public mpv-mpris
(package
(name "mpv-mpris")
diff --git a/tests/graph.scm b/tests/graph.scm
index 6674b5cc8f..a6186ff7e8 100644
--- a/tests/graph.scm
+++ b/tests/graph.scm
@@ -477,7 +477,7 @@ edges."
'("libffi" "guile" "guile-json")
(run-with-store %store
(mlet %store-monad ((path (shortest-path (specification->package "libffi")
- guile-json
+ guile-json-1
%reverse-package-node-type)))
(return (map package-name path)))))