aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm33
-rw-r--r--gnu/packages/prometheus.scm35
2 files changed, 35 insertions, 33 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7d6b3a1c1d..b1df96b87c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -72,7 +72,6 @@
#:use-module (gnu packages golang-maths)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages linux)
- #:use-module (gnu packages prometheus) ; for go-github-com-nbrownus-go-metrics-prometheus
#:use-module (gnu packages specifications))
;;; Commentary:
@@ -3946,38 +3945,6 @@ varints.")
very fast, and tries to be entropy pool friendly.")
(license license:asl2.0)))
-(define-public go-github-com-nbrownus-go-metrics-prometheus
- (package
- (name "go-github-com-nbrownus-go-metrics-prometheus")
- (version "0.0.0-20210712211119-974a6260965f")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nbrownus/go-metrics-prometheus")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
- (build-system go-build-system)
- (arguments
- (list
- ;; The project looks abandoned, tests failed with a new go-metrics.
- #:tests? #f
- #:import-path "github.com/nbrownus/go-metrics-prometheus"))
- (native-inputs
- (list go-github-com-stretchr-testify))
- (propagated-inputs
- (list go-github-com-prometheus-client-golang
- go-github-com-rcrowley-go-metrics))
- (home-page "https://github.com/nbrownus/go-metrics-prometheus")
- (synopsis "Prometheus support for go-metrics")
- (description
- "This package provides a reporter for the @code{go-metrics} library which
-posts the metrics to the Prometheus client registry and just updates the
-registry.")
- (license license:asl2.0)))
-
(define-public go-github-com-neurosnap-sentences
(package
(name "go-github-com-neurosnap-sentences")
diff --git a/gnu/packages/prometheus.scm b/gnu/packages/prometheus.scm
index 860bb74017..c61d107234 100644
--- a/gnu/packages/prometheus.scm
+++ b/gnu/packages/prometheus.scm
@@ -2,7 +2,9 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
+;;; Copyright © 2024 Dominic Martinez <dom@dominicm.dev>
;;; Copyright © 2024 Jesse Eisses <jesse@eisses.email>
+;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -88,6 +90,39 @@ x/net/trace)} tracing wrappers @code{net.Conn}, both inbound
(@@code{net.Listener}) and outbound (@@code{net.Dialer}).")
(license license:asl2.0)))
+(define-public go-github-com-nbrownus-go-metrics-prometheus
+ (package
+ (name "go-github-com-nbrownus-go-metrics-prometheus")
+ (version "0.0.0-20210712211119-974a6260965f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nbrownus/go-metrics-prometheus")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1kl9l08aas544627zmhkgp843qx94sxs4inxm20nw1hx7gp79dz0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; The project looks abandoned, tests failed with a new go-metrics, see
+ ;; <https://github.com/nbrownus/go-metrics-prometheus/pull/2>.
+ #:tests? #f
+ #:import-path "github.com/nbrownus/go-metrics-prometheus"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-prometheus-client-golang
+ go-github-com-rcrowley-go-metrics))
+ (home-page "https://github.com/nbrownus/go-metrics-prometheus")
+ (synopsis "Prometheus support for go-metrics")
+ (description
+ "This package provides a reporter for the @code{go-metrics} library which
+posts the metrics to the Prometheus client registry and just updates the
+registry.")
+ (license license:asl2.0)))
+
(define-public go-github-com-prometheus-client-golang
(package
(name "go-github-com-prometheus-client-golang")