aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 40c14745fa..542ed5945a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9305,8 +9305,16 @@ management tools in userspace.")
(build-system go-build-system)
(arguments
(list
- #:tests? #f ; Tests depend on specific kernel modules.
- #:import-path "github.com/vishvananda/netlink"))
+ #:import-path "github.com/vishvananda/netlink"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; Disable tests requiring root access.
+ (("TestNetNsIdByFd") "OffTestNetNsIdByFd")
+ (("TestNetNsIdByPid") "OffTestNetNsIdByPid"))))))))
(propagated-inputs
(list go-golang-org-x-sys go-github-com-vishvananda-netns))
(home-page "https://github.com/vishvananda/netlink")