aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--po/guix/Makevars5
-rw-r--r--po/packages/Makevars5
3 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f8b9376c1f..583b902361 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@ dnl For the C++ code. This must be used early.
AC_USE_SYSTEM_EXTENSIONS
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION([0.18.1])
+AM_GNU_GETTEXT_VERSION([0.19.1])
GUIX_SYSTEM_TYPE
GUIX_ASSERT_SUPPORTED_SYSTEM
diff --git a/po/guix/Makevars b/po/guix/Makevars
index 363bf98dfd..88a4e8c7bc 100644
--- a/po/guix/Makevars
+++ b/po/guix/Makevars
@@ -26,3 +26,8 @@ EXTRA_LOCALE_CATEGORIES =
# "make distcheck -j4".
# See <https://lists.gnu.org/archive/html/bug-gettext/2014-08/msg00005.html>.
DIST_DEPENDS_ON_UPDATE_PO = no
+
+# Ignore the timestamp of the .pot file, as .po files are updated by
+# `make download-po` only. This ensures po files are not modified on the
+# first `make` invocation.
+PO_DEPENDS_ON_POT = no
diff --git a/po/packages/Makevars b/po/packages/Makevars
index 39366fbee9..4cdb98d8fe 100644
--- a/po/packages/Makevars
+++ b/po/packages/Makevars
@@ -22,3 +22,8 @@ EXTRA_LOCALE_CATEGORIES =
# "make distcheck -j4".
# See <https://lists.gnu.org/archive/html/bug-gettext/2014-08/msg00005.html>.
DIST_DEPENDS_ON_UPDATE_PO = no
+
+# Ignore the timestamp of the .pot file, as .po files are updated by
+# `make download-po` only. This ensures po files are not modified on the
+# first `make` invocation.
+PO_DEPENDS_ON_POT = no