aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d0548c2ac2..a504bb521b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13379,9 +13379,8 @@ database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(add-before 'build 'patch-setup-py
(lambda _
(substitute* "setup.py"
- ;; Newer versions of keyring produce a package with version "0.0.0"
- ;; Reported upstream: <https://github.com/jaraco/keyring/issues/469>
- (("keyring>=21.2.0,<22.0.0") "keyring>=21.0.0,<22.0.0")
+ ;; Allow newer versions of python-keyring.
+ (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
;; TODO: remove after the next release cycle,
;; when packaging has been updated.
(("packaging>=20.4,<21.0") "packaging>=20.0,<21.0"))