aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/emulators.scm5
-rw-r--r--gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch36
3 files changed, 2 insertions, 40 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4ea11ac1b9..0c9c5cff18 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1723,7 +1723,6 @@ dist_patch_DATA = \
%D%/packages/patches/mrrescue-support-love-11.patch \
%D%/packages/patches/mtools-mformat-uninitialized.patch \
%D%/packages/patches/mupen64plus-ui-console-notice.patch \
- %D%/packages/patches/mupen64plus-video-z64-glew-correct-path.patch \
%D%/packages/patches/musl-cross-locale.patch \
%D%/packages/patches/mutt-store-references.patch \
%D%/packages/patches/m17n-lib-1.8.0-use-pkg-config-for-freetype.patch \
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 9b5b69fabc..090741c544 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1238,7 +1238,7 @@ Rice Video plugin.")
(define-public mupen64plus-video-z64
(package
(name "mupen64plus-video-z64")
- (version "2.0.0")
+ (version "2.5.9")
(source
(origin
(method git-fetch)
@@ -1247,8 +1247,7 @@ Rice Video plugin.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "04qa2fdd6dakpk2v0d4l80xh9b4h8gm71g80c0wyyxdhmhwk1r9c"))
- (patches (search-patches "mupen64plus-video-z64-glew-correct-path.patch"))))
+ (base32 "1i8dxa0lhcsm5ss1bf74dqnzaa2bw5naj6f56ixw2qjvybrnsmk2"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config which))
diff --git a/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch b/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch
deleted file mode 100644
index c3fcfbbd0e..0000000000
--- a/gnu/packages/patches/mupen64plus-video-z64-glew-correct-path.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 21507b3600c616bca7049004eb518cf11f45f299 Mon Sep 17 00:00:00 2001
-From: "Anthony J. Bentley" <anthony@cathet.us>
-Date: Sun, 7 Jun 2015 02:41:28 -0600
-Subject: [PATCH] Correct the path to the GLEW header.
-
----
- src/glshader.cpp | 2 +-
- src/rgl.h | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/glshader.cpp b/src/glshader.cpp
-index 4729945..a8947ea 100644
---- a/src/glshader.cpp
-+++ b/src/glshader.cpp
-@@ -23,7 +23,7 @@
- #include <stdio.h>
- #include <string.h>
- #include "rgl_assert.h"
--#include <glew.h>
-+#include <GL/glew.h>
- #if defined(__MACOSX__)
- #include <OpenGL/gl.h>
- #include <OpenGL/glext.h>
-diff --git a/src/rgl.h b/src/rgl.h
-index c15f93f..1748406 100644
---- a/src/rgl.h
-+++ b/src/rgl.h
-@@ -26,7 +26,7 @@
- #include "rgl_assert.h"
- #include "rdp.h"
-
--#include <glew.h>
-+#include <GL/glew.h>
- #if defined(__MACOSX__)
- #include <OpenGL/gl.h>
- #elif defined(__MACOS__)