aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8002f24110..2862cb1187 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5582,7 +5582,7 @@ simultaneously.")
(define-public ncbi-vdb
(package
(name "ncbi-vdb")
- (version "2.9.3")
+ (version "2.9.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5591,11 +5591,12 @@ simultaneously.")
(file-name (git-file-name name version))
(sha256
(base32
- "1l4ny67nxwv1lagk9wwjbrgm7ln7adci6dnpc7k1yaln6shj0qpm"))))
+ "0knkj1sq34hlivgv5qd6jlczqrs3ldmfgn6vbbw7p4mqxvb9mirk"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; not supported
#:tests? #f ; no "check" target
+ #:make-flags '("HAVE_HDF5=1")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-files-writable
@@ -5607,6 +5608,13 @@ simultaneously.")
(string-append (getcwd) "/setup:"
(getenv "PERL5LIB")))
#t))
+ ;; See https://github.com/ncbi/ncbi-vdb/issues/14
+ (add-after 'unpack 'patch-krypto-flags
+ (lambda _
+ (substitute* "libs/krypto/Makefile"
+ (("-Wa,-march=generic64\\+aes") "")
+ (("-Wa,-march=generic64\\+sse4") ""))
+ #t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))