aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-check.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 382a5453bb..4eb6cb1a10 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2439,42 +2439,6 @@ reducing a number of combinations of variables into a lesser set that covers
most situations.")
(license license:expat)))
-(define-public python-pytest-mp
- (package
- (name "python-pytest-mp")
- (version "0.0.4p2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ansible/pytest-mp")
- (commit "49a8ff2ca9ef62d8c86854ab31d6b5d5d6cf3f28")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "01v98b6n3yvkfmxf2v38xk5ijqlk6ika0yljwkhl5bh6qhq23498"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-pytest python-psutil))
- (arguments
- ;; tests require setuptools-markdown, which is deprecated and not in guix
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-useless-requirements
- (lambda _
- (substitute* "setup.py"
- ((" setup_requires=") " #")))))))
- (home-page "https://github.com/ansible/pytest-mp")
- (synopsis "Segregate tests into several processes")
- (description "pytest-mp is a minimalist approach to distribute and
-segregate pytest tests across processes using python's multiprocessing library
-and is heavily inspired by pytest-concurrent and pytest-xdist. As a very
-early beta, it doesn't pledge or intend to support the majority of platforms
-or use cases. Design is based on supporting slow, io-bound testing with often
-tedious system under test configuration that can benefit from running several
-tests at one time.")
- (license license:expat)))
-
(define-public python-aioresponses
(package
(name "python-aioresponses")