aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm2
-rw-r--r--gnu/packages/golang.scm3
-rw-r--r--guix/cpu.scm6
3 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 3abecdeadd..3555d12c44 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -624,7 +624,7 @@ Go. It also includes runtime support libraries for these languages.")
"btver1" "btver2" ;AMD
;; psABI micro-architecture levels
- "x86-64-v1" "x86-64-v2" "x86-64-v3" "x86-64-v4")))
+ "x86-64" "x86-64-v2" "x86-64-v3" "x86-64-v4")))
;; Suitable '-march' values for GCC 12.
(define %gcc-12-aarch64-micro-architectures
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 670056f8a0..49e25320fa 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -870,7 +870,8 @@ in the style of communicating sequential processes (@dfn{CSP}).")
("powerpc64le" ,@%go-1.17-powerpc64le-micro-architectures))))))
(define %go-1.18-x86_64-micro-architectures
- (list "x86-64-v1" "x86-64-v2" "x86-64-v3" "x86-64-v4"))
+ ;; GOAMD defaults to 'v1' so we match the default elsewhere.
+ (list "x86-64" "x86-64-v2" "x86-64-v3" "x86-64-v4"))
(define-public go-1.18
(package
diff --git a/guix/cpu.scm b/guix/cpu.scm
index b69c9b5360..6f9e8daa61 100644
--- a/guix/cpu.scm
+++ b/guix/cpu.scm
@@ -294,8 +294,8 @@ correspond roughly to CPU, a record as returned by 'current-cpu'."
("avx" "avx2" "bmi1" "bmi2" "f16c" "fma" "movbe"
"popcnt" "sse3" "sse4_1" "sse4_2" "ssse3" => "x86-64-v3")
("popcnt" "sse3" "sse4_1" "sse4_2" "ssse3" => "x86-64-v2")
- (_ => "x86-64-v1")))
- "x86-64-v1"))
+ (_ => "x86-64")))
+ "x86-64"))
(architecture
;; TODO: More architectures
architecture)))
@@ -321,5 +321,5 @@ CPUs for compilers which don't allow for more focused optimizing."
"btver2" "athalon" "k8-sse3" "k8" "bdver3" "bdver2" "bdver1" "btver1"
"amdfam10"
"lujiazui" "yongfeng" "x86-64")
- "x86-64-v1")
+ "x86-64")
(_ gcc-architecture)))