aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index df98bd2fa8..becd15d523 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2383,17 +2383,18 @@ lookup to YAML Mode. You could enable the mode with @code{(add-hook
`(#:phases (modify-phases %standard-phases
(delete 'configure)
(replace 'build
- (lambda _
- (invoke "make" (string-append "CC=" ,(cc-for-target)) "-Csrc")))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "-Csrc" make-flags)))
(replace 'check
- (lambda _
- (invoke "make" (string-append "CC=" ,(cc-for-target)) "-Ctests")))
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "-Ctests" make-flags)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin")))
(install-file "src/cpulimit" bin))
- #t)))))
+ #t)))
+ #:make-flags (list (string-append "CC=" ,(cc-for-target)))))
(home-page "https://github.com/opsengine/cpulimit")
(synopsis "Limit CPU usage")
(description