aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5e8a3654ab..5d492d073c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5273,19 +5273,30 @@ Server (PLS).")
(define-public python-lsp-server
(package
(name "python-lsp-server")
- (version "1.5.0")
+ (version "1.3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-lsp-server" version))
(sha256
(base32
- "039qi5x9sa1mjzinimxhiwzj8lxn5d5l33q6qhkjl0i5k70r9h75"))))
+ "0h6wxzmm6qjfwkkn3mnzn1fpmcp23fpbk74bi8p540q1nzccqj0v"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp")))
+ (replace 'check
+ (lambda _
+ ;; Disable failing test.
+ (invoke "python" "-m" "pytest" "-k"
+ "not test_pyqt_completion"))))))
(propagated-inputs
(list python-autopep8
python-pydocstyle
python-flake8
+ python-future
python-jedi
python-lsp-jsonrpc
python-pluggy
@@ -5298,12 +5309,13 @@ Server (PLS).")
(list python-coverage
python-flaky
python-matplotlib
+ python-mock
python-numpy
python-pandas
python-pylint
python-pytest
python-pytest-cov
- python-whatthepatch))
+ python-versioneer))
(home-page "https://github.com/python-lsp/python-lsp-server")
(synopsis "Python implementation of the Language Server Protocol")
(description