aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 9a01c78a1d..71b35894d9 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@pobox.com>
;;; Copyright © 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
@@ -841,7 +841,11 @@ which speak the Qualcomm MSM Interface (QMI) protocol.")
(build-system gnu-build-system)
(arguments
'(#:configure-flags
- `(,(string-append "--with-udev-base-dir=" %output "/lib/udev"))))
+ `(,(string-append "--with-udev-base-dir=" %output "/lib/udev")
+ ;; FIXME: Without this flag the build fails with "error: assignment
+ ;; from incompatible pointer type" whenever the return value of
+ ;; "g_object_ref" is assigned to "ctx->self".
+ "--disable-more-warnings")))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums
("gobject-introspection" ,gobject-introspection)