aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/patches/libgda-disable-data-proxy-test.patch59
3 files changed, 61 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2e269faf51..a2f41c7e95 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1582,6 +1582,7 @@ dist_patch_DATA = \
%D%/packages/patches/libcyaml-libyaml-compat.patch \
%D%/packages/patches/libexpected-use-provided-catch2.patch \
%D%/packages/patches/libgda-cve-2021-39359.patch \
+ %D%/packages/patches/libgda-disable-data-proxy-test.patch \
%D%/packages/patches/libgda-fix-build.patch \
%D%/packages/patches/libgda-fix-missing-initialization.patch \
%D%/packages/patches/libgda-skip-postgresql-tests.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 97e7f25532..7e7d77a3a2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -13505,6 +13505,7 @@ developed with the aim of being used with the Librem 5 phone.")
(sha256
(base32 "0w564z7krgjk19r39mi5qn4kggpdg9ggbyn9pb4aavb61r14npwr"))
(patches (search-patches "libgda-cve-2021-39359.patch"
+ "libgda-disable-data-proxy-test.patch"
"libgda-fix-build.patch"
"libgda-fix-missing-initialization.patch"
"libgda-skip-postgresql-tests.patch"))))
diff --git a/gnu/packages/patches/libgda-disable-data-proxy-test.patch b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
new file mode 100644
index 0000000000..b93f9d3f9b
--- /dev/null
+++ b/gnu/packages/patches/libgda-disable-data-proxy-test.patch
@@ -0,0 +1,59 @@
+From c0bb1ed662011207ee13d5a20a70f9b55166aa13 Mon Sep 17 00:00:00 2001
+From: Daniel Espinosa <esodan@gmail.com>
+Date: Wed, 1 Nov 2023 15:00:40 -0500
+Subject: [PATCH] GdaDataProxy: is no thread save so disabling its test
+
+Has been difficutl to reproduce the problem when this test
+is running in Ci, so disabling until we can re-implement it
+is the better choice
+---
+ libgda/gda-data-proxy.h | 4 +++-
+ tests/data-models/meson.build | 17 +++++++++--------
+ 2 files changed, 12 insertions(+), 9 deletions(-)
+
+diff --git a/libgda/gda-data-proxy.h b/libgda/gda-data-proxy.h
+index 4c31ab69b..ba0fa72b3 100644
+--- a/libgda/gda-data-proxy.h
++++ b/libgda/gda-data-proxy.h
+@@ -77,7 +77,9 @@ struct _GdaDataProxyClass
+ * @stability: Stable
+ * @see_also: #GdaDataModel
+ *
+- * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
++ * This object, is no thread save, so use with care.
++ *
++ * This object stores modifications to be made to a #GdaDataModel object which is proxied until the modifications are actually
+ * written to the #GdaDataModel, it can also filter the proxied data model to show only a subset (a defined number of continuous
+ * rows or by a filter to apply).
+ *
+diff --git a/tests/data-models/meson.build b/tests/data-models/meson.build
+index a8c6a29d8..e0ec8692a 100644
+--- a/tests/data-models/meson.build
++++ b/tests/data-models/meson.build
+@@ -61,14 +61,15 @@ tchkdp = executable('check_data_proxy',
+ ],
+ install: false
+ )
+-test('DataProxy', tchkdp,
+- timeout: 100,
+- workdir: meson.current_build_dir(),
+- env: [
+- 'GDA_TOP_SRC_DIR='+gda_top_src,
+- 'GDA_TOP_BUILD_DIR='+gda_top_build
+- ]
+- )
++# This test is no thread save so disabling
++#test('DataProxy', tchkdp,
++# timeout: 100,
++# workdir: meson.current_build_dir(),
++# env: [
++# 'GDA_TOP_SRC_DIR='+gda_top_src,
++# 'GDA_TOP_BUILD_DIR='+gda_top_build
++# ]
++# )
+
+ tchkmc = executable('check_model_copy',
+ ['check_model_copy.c'] + common_sources,
+--
+GitLab
+