aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/benchmark.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/benchmark.scm b/gnu/packages/benchmark.scm
index 0cc8def918..d764e64571 100644
--- a/gnu/packages/benchmark.scm
+++ b/gnu/packages/benchmark.scm
@@ -634,7 +634,12 @@ its features are:
;; Do not attempt to invoke the cram command via
;; Python, as on Guix it is a shell script (wrapper).
(("\\$\\(command -v cram\\)")
- "-m cram"))))
+ "-m cram"))
+ (substitute* "tests/t/opt_report_checkpoints.t"
+ ;; egrep outputs a deprecation warning, which breaks
+ ;; the test.
+ (("egrep")
+ "grep -E"))))
(add-after 'unpack 'disable-test-installation
(lambda _
(substitute* "tests/Makefile.am"