aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ssh.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index caa8c783ea..cd92c62f58 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -329,25 +329,21 @@ libssh library.")
"1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
(build-system gnu-build-system)
(arguments
- ;; Replace configure phase as the ./configure script does not link
- ;; CONFIG_SHELL and SHELL passed as parameters
`(#:phases
(modify-phases %standard-phases
(replace 'configure
- (lambda* (#:key outputs inputs system build target
- #:allow-other-keys #:rest args)
- (let* ((configure (assoc-ref %standard-phases 'configure))
- (prefix (assoc-ref outputs "out"))
- (bash (which "bash"))
+ ;; Replace configure phase as the ./configure script does not like
+ ;; CONFIG_SHELL and SHELL passed as parameters
+ (lambda* (#:key outputs build target #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (which "bash"))
;; Set --build and --host flags as the provided config.guess
;; is not able to detect them
- (flags `(,(string-append "--prefix=" prefix)
+ (flags `(,(string-append "--prefix=" out)
,(string-append "--build=" build)
,(string-append "--host=" (or target build)))))
(setenv "CONFIG_SHELL" bash)
- (apply invoke bash
- (string-append "." "/configure")
- flags))))
+ (apply invoke bash "./configure" flags))))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))