aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/syncthing.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0f12b58487..f95e74a4ea 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1040,6 +1040,30 @@ submodules:
metrics to Graphite.")
(license license:bsd-2)))
+(define-public go-github-com-d4l3k-messagediff
+ (package
+ (name "go-github-com-d4l3k-messagediff")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/d4l3k/messagediff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "104hl8x57ciaz7mzafg1vp9qggxcyfm8hsv9bmlihbz9ml3nyr8v"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/d4l3k/messagediff"))
+ (home-page "https://github.com/d4l3k/messagediff")
+ (synopsis "Diff arbitrary Go structs")
+ (description
+ "Messagediff is a library for calculating diffs of arbitrary
+structs in the Go programming language.")
+ (license license:expat)))
+
(define-public go-github-com-danwakefield-fnmatch
(let ((commit "cbb64ac3d964b81592e64f957ad53df015803288")
(revision "0"))
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index fba79da7e2..09d62f57fd 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -258,28 +258,6 @@ reflection.")
(home-page "https://github.com/calmh/xdr")
(license expat)))
-(define-public go-github-com-d4l3k-messagediff
- (package
- (name "go-github-com-d4l3k-messagediff")
- (version "1.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/d4l3k/messagediff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "104hl8x57ciaz7mzafg1vp9qggxcyfm8hsv9bmlihbz9ml3nyr8v"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/d4l3k/messagediff"))
- (synopsis "Diff arbitrary Go structs")
- (description "Messagediff is a library for calculating diffs of arbitrary
-structs in the Go programming language.")
- (home-page "https://github.com/d4l3k/messagediff")
- (license expat)))
-
(define-public go-github-com-vitrun-qart
(let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
(revision "0"))