aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/erlang.scm4
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/gtk.scm2
-rw-r--r--gnu/packages/haskell.scm4
-rw-r--r--gnu/packages/julia-xyz.scm2
-rw-r--r--gnu/packages/ocaml.scm4
-rw-r--r--gnu/packages/python-xyz.scm4
-rw-r--r--gnu/packages/version-control.scm7
8 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index cfada5a619..dc9a932aec 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -376,7 +376,7 @@ Markdown.")
(propagated-inputs
(list erlang-cf))
(native-inputs
- (list git-minimal/fixed)) ;; Required for tests
+ (list git-minimal/pinned)) ;; Required for tests
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -701,7 +701,7 @@ applications as a dependent libraries.")
(base32 "1dfz56034pa25axly9vqdzv3phkn8ll0qwrkws96pbgcprhky1hx"))))
(build-system rebar-build-system)
(inputs
- (list git-minimal/fixed))
+ (list git-minimal/pinned))
(arguments
`(;; Running the tests require binary artifact (tar-file containing
;; samples git repos) TODO: remove these from the source
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4f2d716fb2..6a4d3182b2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -909,7 +909,7 @@ tomorrow, the rest of the week and for special occasions.")
(list dbus
desktop-file-utils
gettext-minimal
- git-minimal/fixed
+ git-minimal/pinned
`(,glib "bin")
gobject-introspection
gsettings-desktop-schemas
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5024455368..f575194c73 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2519,7 +2519,7 @@ Parcellite and adds bugfixes and features.")
'("-Dintrospection=false")
'()))))
(native-inputs
- `(("git" ,git-minimal/fixed)
+ `(("git" ,git-minimal/pinned)
("gobject-introspection" ,gobject-introspection)
("mutest" ,mutest)
("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 91610a1f2e..4eb13f76d7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1143,7 +1143,7 @@ interactive environment for the functional language Haskell.")
(sha256
(base32
"0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
@@ -1195,7 +1195,7 @@ interactive environment for the functional language Haskell.")
(sha256
(base32
"1zl25gg6bpx5601k8h3cqnns1xfc0nqgwnh8jvn2s65ra3f2g1nz"))))
- ("git" ,git-minimal/fixed) ; invoked during tests
+ ("git" ,git-minimal/pinned) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
(("ghc-testsuite" . _) #f)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 414aba03f0..b831b41db2 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1614,7 +1614,7 @@ valuable enough at this time.")
(inputs
(list python-wrapper))
(native-inputs
- (list git-minimal/fixed ;needed for the "Utilities" test
+ (list git-minimal/pinned ;needed for the "Utilities" test
julia-documentermarkdown
julia-documentertools))
(home-page "https://juliadocs.github.io/Documenter.jl")
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 3458c87818..0cc92c3e85 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -938,7 +938,7 @@ name = Guix Builder")
("ocaml-cppo" ,ocaml-cppo)
;; For tests.
- ("git" ,git-minimal/fixed)
+ ("git" ,git-minimal/pinned)
("openssl" ,openssl)
("python" ,python-wrapper)
("rsync" ,rsync)
@@ -8656,7 +8656,7 @@ defined in OCaml 4.12.0.")
ocaml-uuseg
ocaml-uutf))
(native-inputs
- (list git-minimal/fixed ;for tests
+ (list git-minimal/pinned ;for tests
ocaml-alcotest ocaml-ocp-indent ocaml-bisect-ppx))
(home-page "https://github.com/ocaml-ppx/ocamlformat")
(synopsis "Auto-formatter for OCaml code")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b7975c2db4..1cad8e54d8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25933,7 +25933,7 @@ also be usable with other GSSAPI mechanisms.")
(invoke "git" "config" "--global"
"protocol.file.allow" "always"))))))
(native-inputs
- (list git-minimal/fixed python-pytest))
+ (list git-minimal/pinned python-pytest))
(propagated-inputs
(list python-pypa-build python-setuptools python-tomli))
(home-page "https://github.com/mgedmin/check-manifest")
@@ -28578,7 +28578,7 @@ and frame grabber interface.")
(native-inputs
(list cmake-minimal
gfortran
- git-minimal/fixed ;for tests
+ git-minimal/pinned ;for tests
ninja
python-coverage
python-cython
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 78a89cfd5b..12e21336ce 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -67,6 +67,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix utils)
#:use-module (guix packages)
+ #:use-module (guix deprecation)
#:use-module (guix gexp)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -670,7 +671,11 @@ everything from small to very large projects with speed and efficiency.")
perl
zlib))))
-(define-public git-minimal/fixed
+;;; The symbol git-minimal/fixed should be used when git-minimal needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias git-minimal/fixed git-minimal/pinned)
+
+(define-public git-minimal/pinned
;; Version that rarely changes, depended on by Graphene/GTK+.
(package/inherit git-minimal
(version "2.33.1")