aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/maths.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e2c0492ccb..fade383ca7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5246,6 +5246,39 @@ It is a variant of AMD which has the the option to apply constraints to the
ordering.")
(license license:bsd-3)))
+(define-public suitesparse-colamd
+ (package
+ (name "suitesparse-colamd")
+ (version "3.2.0")
+ (source suitesparse-source)
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "COLAMD")))
+ (add-after 'chdir 'set-cmake-module-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("set.*CMAKE_MODULE_PATH.*")
+ (string-append "set(CMAKE_MODULE_PATH "
+ #$suitesparse-config "/lib/cmake/SuiteSparse)\n"
+ "set(DUMMY\n")))))
+ (replace 'install-license-files
+ (lambda _
+ (install-file "../COLAMD/Doc/License.txt"
+ (string-append #$output "/share/doc/"
+ #$name "-" #$version)))))))
+ (inputs (list suitesparse-config))
+ (home-page "https://people.engr.tamu.edu/davis/suitesparse.html")
+ (synopsis "Column Approximate Minimum Degree Ordering")
+ (description "COLAMD is library for computing a permutation vector for a
+matrix with which the LU factorization becomes sparser.")
+ (license license:bsd-3)))
+
(define-public suitesparse
(package
(name "suitesparse")