aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b4b247e87f..bc02fbd830 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1352,6 +1352,48 @@ which is capable of accurately playing many games. This package contains the
SDL input plugin.")
(license license:gpl2+)))
+(define-public mupen64plus-rsp-hle
+ (package
+ (name "mupen64plus-rsp-hle")
+ (version "2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mupen64plus/mupen64plus-rsp-hle/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "15h7mgz6xd2zjzm6l3f96sbs8kwr3xvbwzgikhnka79m6c69hsxv"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("mupen64plus-core" ,mupen64plus-core)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ ;; The mupen64plus build system has no configure phase.
+ (delete 'configure)
+ ;; Makefile is in a subdirectory.
+ (add-before
+ 'build 'cd-to-project-dir
+ (lambda _
+ (chdir "projects/unix"))))
+ #:make-flags
+ (let ((out (assoc-ref %outputs "out"))
+ (m64p (assoc-ref %build-inputs "mupen64plus-core")))
+ (list "all"
+ (string-append "PREFIX=" out)
+ (string-append "APIDIR=" m64p "/include/mupen64plus")))
+ ;; There are no tests.
+ #:tests? #f))
+ (home-page "http://www.mupen64plus.org/")
+ (synopsis "Mupen64Plus SDL input plugin")
+ (description
+ "Mupen64Plus is a cross-platform plugin-based Nintendo 64 (N64) emulator
+which is capable of accurately playing many games. This package contains the
+high-level emulation (HLE) RSP processor plugin.")
+ (license license:gpl2+)))
+
(define-public nestopia-ue
(package
(name "nestopia-ue")