aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/admin.scm25
-rw-r--r--gnu/system.scm2
2 files changed, 8 insertions, 19 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index da832ac5c3..b2aadcc458 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -932,7 +932,13 @@ hostname.")
(substitute* "lib/nscd.c"
(("/usr/sbin/nscd")
(string-append libc "/sbin/nscd"))))))
- (add-after 'install 'remove-groups
+ (add-after 'install 'install-man-pages
+ (lambda _
+ ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
+ ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
+ ;; pages are available. Thus, install them manually.
+ (invoke "make" "-C" "man" "install")))
+ (add-after 'install-man-pages 'remove-groups
(lambda* (#:key outputs #:allow-other-keys)
;; Remove `groups', which is already provided by Coreutils.
(let* ((out (assoc-ref outputs "out"))
@@ -953,27 +959,10 @@ hostname.")
"Shadow provides a number of authentication-related tools, including:
login, passwd, su, groupadd, and useradd.")
- (properties '((hidden? . #t))) ;see below
-
;; The `vipw' program is GPLv2+.
;; libmisc/salt.c is public domain.
(license license:bsd-3)))
-(define-public shadow-with-man-pages
- ;; TODO: Merge with 'shadow' on the next core-updates cycle.
- (package/inherit shadow
- (properties '()) ;not hidden
- (arguments
- (substitute-keyword-arguments (package-arguments shadow)
- ((#:phases phases '%standard-phases)
- `(modify-phases ,phases
- (add-after 'install 'install-man-pages
- (lambda _
- ;; The top-level Makefile.am wrongfully has "SUBDIRS += man"
- ;; under "if ENABLE_REGENERATE_MAN", even though prebuilt man
- ;; pages are available. Thus, install them manually.
- (invoke "make" "-C" "man" "install")))))))))
-
(define-public mingetty
(package
(name "mingetty")
diff --git a/gnu/system.scm b/gnu/system.scm
index a94f0a9a1f..9c2e50bec5 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -846,7 +846,7 @@ of PROVENANCE-SERVICE-TYPE to its services."
(define %base-packages-utils
;; Default set of utilities packages.
(cons* procps psmisc which
- (@ (gnu packages admin) shadow-with-man-pages) ;for 'passwd'
+ shadow ;for 'passwd'
guile-3.0-latest