aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 8d18cce4b2..797c921c9c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -7849,6 +7849,30 @@ system calls.")
(properties '((hidden? . #t)))
(license license:expat)))
+(define-public rust-ref-cast-0.2
+ (package
+ (name "rust-ref-cast")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ref-cast" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jgj1zxaikqm030flpifbp517fy4z21lly6ysbwyciii39bkzcf1"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-ref-cast-impl" ,rust-ref-cast-impl-0.2))))
+ (home-page "https://github.com/dtolnay/ref-cast")
+ (synopsis "Safely cast &T to &U")
+ (description
+ "Safely cast &T to &U where the struct U contains a single field of type T.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-regex-1.1
(package
(name "rust-regex")