aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 765a5a2b4c..b38b2835fb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5182,6 +5182,49 @@ code formatter. It outputs CWL in a standardized YAML format.")
and v1.1 to v1.2.")
(license license:asl2.0)))
+(define-public python-cwl-utils
+ (package
+ (name "python-cwl-utils")
+ (version "0.32")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "cwl-utils" version))
+ (sha256
+ (base32
+ "06wkw8d8cqm3hnz8xwnysz874gwaym36c358cr7frw5iglhvsj98"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k"
+ (string-append "not test_graph_split"
+ " and not test_load_document_with_remote_uri"
+ " and not test_remote_packing"
+ " and not test_remote_packing_github_soft_links"
+ " and not test_value_from_two_concatenated_expressions"))))
+ (inputs
+ (list node))
+ (native-inputs
+ (list python-mypy-extensions
+ python-pytest
+ python-pytest-mock
+ python-pytest-runner))
+ (propagated-inputs
+ (list python-cwl-upgrader
+ python-cwlformat
+ python-packaging
+ python-rdflib
+ python-requests
+ python-ruamel.yaml
+ python-schema-salad))
+ (home-page "https://github.com/common-workflow-language/cwl-utils")
+ (synopsis "Python utilities for CWL")
+ (description "@code{python-cwl-utils} provides python utilities and
+autogenerated classes for loading and parsing CWL v1.0, CWL v1.1, and CWL v1.2
+documents.")
+ (license license:asl2.0)))
+
(define-public cwltool
(package
(name "cwltool")