aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c6d8de68bc..64d8d31cfe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -510,15 +510,11 @@ guix-binary.%.tar.xz:
cp "$$tarball" "$@.tmp" ; mv "$@.tmp" "$@"
-dist-hook: sync-descriptions gen-ChangeLog gen-AUTHORS
+dist-hook: gen-ChangeLog gen-AUTHORS
dist-hook: assert-no-store-file-names
distcheck-hook: assert-binaries-available assert-final-inputs-self-contained
-sync-descriptions:
- $(AM_V_at)GUIX_PACKAGE_PATH= \
- $(top_builddir)/pre-inst-env guix lint --checkers=gnu-description
-
gen-ChangeLog:
$(AM_V_GEN)if test -d .git; then \
$(top_srcdir)/build-aux/gitlog-to-changelog \
@@ -566,7 +562,7 @@ hydra-jobs.scm: $(GOBJECTS)
"$(top_srcdir)/build-aux/hydra/gnu-system.scm" > "$@.tmp"
$(AM_V_at)mv "$@.tmp" "$@"
-.PHONY: sync-descriptions gen-ChangeLog gen-AUTHORS clean-go make-go
+.PHONY: gen-ChangeLog gen-AUTHORS clean-go make-go
.PHONY: assert-no-store-file-names assert-binaries-available
.PHONY: assert-final-inputs-self-contained